Search Results (54 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2026-87670 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-10-13 4.3 Medium
An authorization logic vulnerability exists in the Brocade Fabric OS versions before 10.0.1 REST API gateway. The internal gate guarding restricted management endpoints relies exclusively on client-controlled HTTP headers. An authenticated user with any valid REST session can spoof these headers to gain unauthorized access to internal management endpoints. This allows low-privilege users to view sensitive chassis metadata, hardware memory patrolling state, and firmware integrity audit logs.
CVE-2026-87671 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-10-13 7.5 High
An out-of-bounds memory read vulnerability exists in the web management daemon of Brocade Fabric OS versions before 10.0.1. Unauthenticated HTTP endpoints process specific URL query parameters without validating array index boundaries or performing numerical range checks. An unauthenticated remote attacker can exploit this issue by sending a single, crafted HTTP request containing extreme numerical values in the query string. This causes an invalid memory dereference, resulting in a crash of the web management process (Denial of Service) and potential temporary management-plane disruption.
CVE-2026-87679 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-10-13 7.2 High
When Brocade Fabric OS versions before 10.0.1 processes trunk configuration operations, the application parses user-supplied list strings into dynamically allocated heap arrays without enforcing boundary checks on the maximum allowable number of elements. An authenticated administrator can exploit this vulnerability via crafted REST API requests containing an excessive number of list delimiters, causing heap corruption that can result in service crash or arbitrary code execution.
CVE-2026-87680 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-10-13 8.8 High
A command injection vulnerability in the REST API management interface of Brocade Fabric OS versions before 10.0.1 allows an authenticated user to execute arbitrary system commands via crafted input parameters.
CVE-2026-87681 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-10-13 6.3 Medium
An Access Control Bypass vulnerability exists in the Role-Based Access Control (RBAC) validation engine of Brocade Fabric OS versions before 10.0.1. When processing certain management protocol operations, the RBAC engine incorrectly categorizes non-standard action opcodes during permission checks. This allows authenticated users with read-only management privileges to bypass access controls and execute restricted administrative operations.
CVE-2025-58382 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-26 7.2 High
A vulnerability in the secure configuration of authentication and management services in Brocade Fabric OS before Fabric OS 9.2.1c2 could allow an authenticated, remote attacker with administrative credentials to execute arbitrary commands as root using “supportsave”, “seccertmgmt”, “configupload” command.
CVE-2025-9711 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-26 7.8 High
A vulnerability in Brocade Fabric OS before 9.2.1c3 could allow elevating the privileges of the local authenticated user to “root” using the export option of seccertmgmt and seccryptocfg commands.
CVE-2024-7517 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-20 7.8 High
A command injection vulnerability in Brocade Fabric OS before 9.2.0c, and 9.2.1 through 9.2.1a on IP extension platforms could allow a local authenticated attacker to perform a privileged escalation via crafted use of the portcfg command. This specific exploitation is only possible on IP Extension platforms: Brocade 7810, Brocade 7840, Brocade 7850 and on Brocade X6 or X7 directors with an SX-6 Extension blade installed. The attacker must be logged into the switch via SSH or serial console to conduct the attack.
CVE-2025-58381 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-06 2.3 Low
A vulnerability in Brocade Fabric OS before 9.2.1c2 could allow an authenticated attacker with admin privileges using the shell commands “source, ping6, sleep, disown, wait to modify the path variables and move upwards in the directory structure or to traverse to different directories.
CVE-2025-58380 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-06 2.3 Low
A vulnerability in Brocade Fabric OS before 9.2.1 could allow an authenticated attacker with admin privileges using the shell command “grep” to modify the path variables and move upwards in the directory structure or to traverse to different directories.
CVE-2025-58379 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-06 5.5 Medium
Brocade Fabric OS before 9.2.1 has a vulnerability that could allow a local authenticated attacker to reveal command line passwords using commands that may expose higher privilege sensitive information by a lower privileged user.
CVE-2025-4661 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2026-02-06 2.3 Low
A path transversal vulnerability in Brocade Fabric OS 9.1.0 through 9.2.2 could allow a local admin user to gain access to files outside the intended directory potentially leading to the disclosure of sensitive information. Note: Admin level privilege is required on the switch in order to exploit
CVE-2017-6227 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2024-11-21 N/A
A vulnerability in the IPv6 stack on Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) versions before 7.4.2b, 8.1.2 and 8.2.0 could allow an attacker to cause a denial of service (CPU consumption and device hang) condition by sending crafted Router Advertisement (RA) messages to a targeted system.
CVE-2017-6225 2 Broadcom, Brocade 2 Fabric Operating System, Fabric Os 2024-11-21 N/A
Cross-site scripting (XSS) vulnerability in the web-based management interface of Brocade Fibre Channel SAN products running Brocade Fabric OS (FOS) versions before 7.4.2b, 8.1.2 and 8.2.0 could allow remote attackers to execute arbitrary code or access sensitive browser-based information.