Description
The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Published: 2026-10-29
Score: n/a
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) performed by privileged users
Action: Patch ASAP
AI Analysis

Impact

The LetterPress WordPress plugin prior to version 2.4.0 fails to properly sanitise and escape certain configuration settings. This flaw enables privileged users, such as administrators, to inject arbitrary JavaScript that is then stored and served to all site visitors, even when the unfiltered_html capability is disabled. An attacker can leverage this to hijack sessions, deface content, or execute additional malicious payloads within the context of the site.

Affected Systems

WordPress installations using LetterPress plugin versions earlier than 2.4.0 are affected. The vulnerability applies to any WordPress site where the plugin is installed and where users have sufficient privileges to modify its settings.

Risk and Exploitability

The attack requires the attacker to possess administrator or equivalent privileges to modify the plugin settings. While no EPSS score or KEV listing is available, the impact of stored XSS at this privilege level is high and constitutes a severe risk. No publicly documented exploit exists, but the vulnerability is easy to exploit by any user with access to the settings interface.

Generated by OpenCVE AI on October 29, 2026 at 07:27 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade LetterPress to version 2.4.0 or later to apply the vendor‑provided sanitisation fix.
  • Restrict or revoke the ability for high‑privilege users to modify plugin settings until an update is available, reducing the attack surface.
  • Apply a Content Security Policy that limits script execution from untrusted sources, mitigating the effect of any XSS payload that might still be present.

Generated by OpenCVE AI on October 29, 2026 at 07:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Thu, 29 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Title LetterPress < 2.4.0 - Admin+ Stored XSS
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-29T06:00:23.500Z

Reserved: 2024-04-10T14:12:39.458Z

Link: CVE-2024-3586

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-29T06:17:16.020

Modified: 2026-10-29T06:17:16.020

Link: CVE-2024-3586

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T07:30:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')