Description
The Live Composer WordPress plugin before 2.1.23 does not sanitise and escape some of its custom post type slug settings before using them in front-end links, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).
Published: 2026-11-07
Score: n/a
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Now
AI Analysis

Impact

The vulnerability arises from the Live Composer WordPress plugin not sanitizing or escaping custom post type slug values before placing them in front‑end URLs. When a high‑privilege user, such as an administrator, creates or edits a partner slug containing malicious JavaScript, that code is stored in the database. Subsequent visitors who view the affected link are forced to load the malicious script, giving the attacker the ability to execute arbitrary JavaScript in the context of the site, steal authentication cookies, or deface content. This is a classic Stored Cross‑Site Scripting flaw.

Affected Systems

The affected product is the Live Composer plugin for WordPress versions older than 2.1.23. No other vendors or product families are listed; the CNA identifies the vendor as Unknown:Live Composer. Because the plugin uses custom post type slugs that are rendered on the public site, any WordPress installation using the vulnerable plugin version is at risk. The exact list of susceptible versions is limited to those preceding the 2.1.23 release, as this is the cutoff for the patch.

Risk and Exploitability

The exploit does not require open network access; an attacker needs the ability to log into the site as a user with the capability to edit partner slugs, typically an administrator or editor. The flaw does not rely on the unfiltered_html capability, meaning even sites that have removed that capability remain vulnerable. EPSS data is not available and the vulnerability is not listed in CISA’s KEV catalog, but stored XSS of this nature can cause significant compromise of user sessions and site integrity. The CVSS score is not provided in the data, so the overall severity must be inferred from the impact on confidentiality, integrity, and availability, with a high potential for privilege escalation and defacement.

Generated by OpenCVE AI on November 7, 2026 at 07:42 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Live Composer to version 2.1.23 or later, which includes input sanitization for partner slugs.
  • If an upgrade is not possible, restrict access to the partner slug editor for non‑trusted users and remove or sanitize any stored slugs manually.
  • Review and delete any custom post type slugs that were created with potentially malicious content, and recreate them using safe characters.
  • Ensure the WordPress site’s security settings disallow the unfiltered_html capability for lower‑privilege users and audit for any remaining XSS vectors.

Generated by OpenCVE AI on November 7, 2026 at 07:42 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 08:00:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Sat, 07 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Live Composer WordPress plugin before 2.1.23 does not sanitise and escape some of its custom post type slug settings before using them in front-end links, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).
Title Live Composer < 2.1.23 - Admin+ Stored XSS via Partner Slug
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-07T06:00:24.639Z

Reserved: 2026-10-29T12:56:44.194Z

Link: CVE-2025-15708

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-07T06:16:56.067

Modified: 2026-11-07T06:16:56.067

Link: CVE-2025-15708

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T07:45:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')