Description
vtenext 25.02 before 25.02.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to change any account password via hub/rpwd.php without token verification. Attackers knowing a valid user_name can send action=change_password to RecoverPwd::displayChangePwd() and log in as administrators lacking two-factor authentication.
Published: 2026-11-04
Score: 9.3 Critical
EPSS: n/a
KEV: No
Impact: Authentication Bypass
Action: Immediate Patch
AI Analysis

Impact

The vulnerability lies in the password recovery component of the vtenext application. A hacker who can determine a valid username may send a request to hub/rpwd.php with action=change_password. Because the script does not validate a token, the system accepts the request and updates the user’s password without any credential checks. This allows an unauthenticated attacker to set a new password for any account, including those with administrative rights, especially if two‑factor authentication is not enabled. The result is a full account takeover and potential compromise of the entire system.

Affected Systems

The issue affects the vtenext CRM product. Versions 25.02 and any releases prior to 25.02.1 are impacted. The vulnerability is tied to the hub/rpwd.php script that processes password change requests.

Risk and Exploitability

The CVSS score of 9.3 marks this flaw as critical. EPSS is not available, so the current exploitation probability is unknown, and the vulnerability is not listed in CISA KEV. Attackers who know a valid username can call hub/rpwd.php with action=change_password, bypassing token verification, and set a new password. Because the mechanism skips authentication checks, anyone can assume any user’s credentials. If the target account has administrative rights or lacks 2‑factor authentication, the attacker can gain unrestricted control of the system. The flaw can be triggered from outside the application over HTTP, making it remotely exploitable.

Generated by OpenCVE AI on November 4, 2026 at 21:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade vtenext to version 25.02.1 or later to apply the patch that enforces token verification in password changes.
  • Enable multi‑factor authentication for all accounts with administrative privileges to reduce the impact if a password is compromised.
  • Review the use of the password change endpoint and consider restricting access, or disable hub/rpwd.php when not needed.

Generated by OpenCVE AI on November 4, 2026 at 21:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 04 Nov 2026 20:45:00 +0000

Type Values Removed Values Added
Description vtenext 25.02 before 25.02.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to change any account password via hub/rpwd.php without token verification. Attackers knowing a valid user_name can send action=change_password to RecoverPwd::displayChangePwd() and log in as administrators lacking two-factor authentication.
Title vtenext 25.02 before 25.02.1 Unverified Password Change via hub/rpwd.php
First Time appeared Vtenext
Vtenext vtenext
Weaknesses CWE-620
CPEs cpe:2.3:a:vtenext:vtenext:*:*:*:*:*:*:*:*
Vendors & Products Vtenext
Vtenext vtenext
References
Metrics cvssV3_1

{'score': 9.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'}

cvssV4_0

{'score': 9.3, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-11-04T20:36:45.211Z

Reserved: 2026-11-04T20:21:24.842Z

Link: CVE-2025-71457

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-04T21:17:40.340

Modified: 2026-11-04T21:17:40.340

Link: CVE-2025-71457

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T21:30:09Z

Weaknesses
  • CWE-620

    Unverified Password Change