Description
The Database Cleaner plugin for WordPress is vulnerable to arbitrary table deletion in all versions up to, and including, 1.4.7. This is due to a lack of restriction on database tables that can be deleted. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete core WordPress tables.
Published: 2026-10-30
Score: 8.7 High
EPSS: n/a
KEV: No
Impact: Arbitrary deletion of WordPress database tables
Action: Apply Patch
AI Analysis

Impact

The Database Cleaner plugin contains a flaw that allows an attacker with Administrator credentials to delete any database table, including core WordPress tables, because the API does not enforce table name restrictions. This lack of authorization control (CWE‑284) results in immediate data loss and site corruption, potentially rendering the WordPress instance unusable. The vulnerability can be exploited by sending deletion requests to the plugin’s REST endpoint with arbitrary table names.

Affected Systems

The issue affects the Database Cleaner plugin for WordPress, version 1.4.7 and all earlier releases, supplied by tigroumeow under the name “Cleanup, Optimization & Repair”. Any WordPress site that has installed one of these plugin versions is vulnerable; the flaw is independent of the underlying operating system or database engine as long as WordPress and the plugin are present.

Risk and Exploitability

With a CVSS score of 8.7 the flaw is considered high severity. The EPSS score is unavailable, and the vulnerability is not listed in the CISA KEV catalog, indicating no known public exploitation. The likely attack vector is authenticated access with Administrator‑level permissions; based on the description, it is inferred that credential compromise could result from brute‑force attacks, credential reuse, or social engineering. Once authenticated, an attacker can call the deletion endpoint and supply any table name, leading to permanent loss of site data across the entire WordPress installation.

Generated by OpenCVE AI on October 30, 2026 at 18:53 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Database Cleaner to a version newer than 1.4.7
  • If upgrading is not immediately possible, disable the Database Cleaner plugin to eliminate the exposure
  • Restrict Administrator accounts to trusted users and enable two‑factor authentication to reduce the risk of credential compromise
  • Configure the database user so that WordPress has limited DELETE rights on critical tables

Generated by OpenCVE AI on October 30, 2026 at 18:53 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The Database Cleaner plugin for WordPress is vulnerable to arbitrary table deletion in all versions up to, and including, 1.4.7. This is due to a lack of restriction on database tables that can be deleted. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete core WordPress tables.
Title Database Cleaner <= 1.4.7 - Authenticated (Administrator+) Arbitrary Table Deletion
Weaknesses CWE-284
References
Metrics cvssV3_1

{'score': 8.7, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T18:08:59.619Z

Reserved: 2025-08-04T23:27:48.418Z

Link: CVE-2025-8574

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:17:13.960

Modified: 2026-10-30T19:17:44.317

Link: CVE-2025-8574

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T19:00:17Z

Weaknesses