Description
The PeproDev Branches Map plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 3.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-14
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Immediately
AI Analysis

Impact

The vulnerability allows authenticated users with Contributor level or higher to insert arbitrary JavaScript into stored content because the plugin does not properly sanitise user input or escape output. When another user views the affected page, the injected script runs in that user’s browser, giving the attacker control of the victim session.

Affected Systems

WordPress sites that have installed any version of the PeproDev Branches Map (Mapify) plugin up to and including 3.0.1 are affected. The plugin is distributed by peprodev and can be downloaded from the WordPress plugin repository. Any WordPress installation that includes a vulnerable instance is at risk.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity, while the EPSS <1% suggests a low probability of exploitation at present. The flaw is not listed in CISA’s KEV catalog. An attacker must be authenticated with Contributor privileges or higher to exploit the issue, after which the injected scripts execute when an end user visits the page. The description does not mention server‑side compromise or database access, so the impact is limited to front‑end script execution.

Generated by OpenCVE AI on October 16, 2026 at 00:03 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade PeproDev Branches Map to version 3.0.2 or later, which removes the input sanitisation flaw.
  • Examine existing content for injected scripts and remove or sanitize any malicious code before it is rendered to users.
  • Limit Contributor access or enforce stricter content review procedures to reduce the risk of future XSS insertions.

Generated by OpenCVE AI on October 16, 2026 at 00:03 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Description The PeproDev Branches Map plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 3.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title PeproDev Branches Map <= 3.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T16:43:49.219Z

Reserved: 2025-08-22T20:30:15.725Z

Link: CVE-2025-9373

cve-icon Vulnrichment

Updated: 2026-10-15T16:39:16.823Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T08:17:02.077

Modified: 2026-10-15T17:17:04.300

Link: CVE-2025-9373

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T00:15:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')