Description
The WP2LEADS plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order’ parameter in all versions up to, and including, 3.5.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2026-10-31
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: SQL Injection
Action: Patch Update
AI Analysis

Impact

The WP2LEADS WordPress plugin contains a time‑based SQL injection vulnerability that is exercised through the order parameter in multiple internal calls. The vulnerability exists because the plugin concatenates the order value directly into a SQL query without adequate escaping or prepared statement use. Because the flaw accepts a user supplied string, an attacker with Subscriber‑level access or higher can embed arbitrary SQL fragments, allowing the extraction of sensitive information from the database. This flaw is a classic example of CWE‑89: Improper Neutralization of Special Elements used in an SQL Command.

Affected Systems

Affected systems are WordPress sites that have the WP2LEADS plugin from vendor tobias_conrad installed at any version up to and including 3.5.6. The issue is present in every release before the fix was released in the 3.5.7 update, and it impacts the entire plugin code base. Sites that have upgraded to newer versions are not vulnerable.

Risk and Exploitability

The reported CVSS score is 6.5, indicating a moderate severity. No EPSS score is available and the CISA KEV catalog does not list this vulnerability, which suggests that exploit data is not yet widely observed. The exploit requires an authenticated user with Subscriber role or higher, meaning the attacker must first obtain site credentials or compromise an existing account. Once authenticated, the attacker can trigger the injection through the plugin’s UI, extending the existing SQL query and reading data otherwise inaccessible to that role. Given the lack of a public exploit and the need for authentication, the immediate risk is moderate but could become high if credentials are compromised or the plugin is used on a multi‑tenant hosting environment.

Generated by OpenCVE AI on October 31, 2026 at 09:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the WP2LEADS plugin to version 3.5.7 or later
  • Disable or remove the WP2LEADS plugin if it is not required for site operations
  • Restrict Subscriber users from accessing the plugin’s administration pages to limit the attack surface

Generated by OpenCVE AI on October 31, 2026 at 09:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 31 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Description The WP2LEADS plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order’ parameter in all versions up to, and including, 3.5.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Title WP2LEADS <= 3.5.6 - Authenticated (Subscriber+) SQL Injection via order Parameter
Weaknesses CWE-89
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-31T07:46:50.489Z

Reserved: 2025-08-25T14:28:23.864Z

Link: CVE-2025-9462

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-31T08:16:47.313

Modified: 2026-10-31T08:16:47.313

Link: CVE-2025-9462

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-31T09:30:14Z

Weaknesses
  • CWE-89

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')