Description
The Security For WooCommerce WordPress plugin from 1.0.10 to 1.0.16 does not perform capability checks when creating users through an action available to unauthenticated visitors, and lets the caller choose the new account's role, allowing unauthenticated attackers to create administrator accounts and take over the site.
Published: 2026-11-05
Score: 9.8 Critical
EPSS: n/a
KEV: No
Impact: Unauthenticated privilege escalation through unrestricted account creation
Action: Immediate Patch
AI Analysis

Impact

The Security For WooCommerce WordPress plugin from version 1.0.10 to 1.0.16 contains a flaw that skips capability checks when creating users via the usfw_create_temporary_user action, which is exposed to unauthenticated visitors. This allows an attacker to specify the role of the newly created account, creating administrator accounts that grant full site control. The vulnerability directly leads to a compromise of confidentiality, integrity, and availability by giving attackers unrestricted administrative access to the WordPress installation.

Affected Systems

Any WordPress site that has the Security For WooCommerce plugin installed in a version from 1.0.10 through 1.0.16 is affected. No other vendors or products are mentioned in the current data.

Risk and Exploitability

The CVSS score of 9.8 indicates a critical severity. No EPSS score is available, and the vulnerability is not currently listed in CISA KEV. The attack vector is an unauthenticated web request to the plugin’s action endpoint, requiring no credentials or prior access. If exploited, an attacker can create a privileged account and take over the entire site.

Generated by OpenCVE AI on November 5, 2026 at 08:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Security For WooCommerce plugin to the latest version, which removes the unauthenticated user creation endpoint.
  • If upgrading is not immediately possible, uninstall the plugin entirely or disable the usfw_create_temporary_user action via a custom code snippet that blocks unauthenticated access to the action.
  • Verify that no newly created administrators exist on the site and audit user accounts for unexpected users.

Generated by OpenCVE AI on November 5, 2026 at 08:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 05 Nov 2026 08:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-284

Thu, 05 Nov 2026 07:45:00 +0000

Type Values Removed Values Added
Description The Security For WooCommerce WordPress plugin from 1.0.10 to 1.0.16 does not perform capability checks when creating users through an action available to unauthenticated visitors, and lets the caller choose the new account's role, allowing unauthenticated attackers to create administrator accounts and take over the site.
Title Security For WooCommerce 1.0.10 - 1.0.16 - Unauthenticated Privilege Escalation via usfw_create_temporary_user
References
Metrics cvssV3_0

{'score': 9.8, 'vector': 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-05T07:35:20.438Z

Reserved: 2026-09-25T11:16:45.144Z

Link: CVE-2026-100109

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-05T08:17:01.870

Modified: 2026-11-05T08:17:01.870

Link: CVE-2026-100109

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-05T08:30:14Z

Weaknesses