Description
The Postie plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Email Body URL Autolink in all versions up to, and including, 1.9.87 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the ?postie=get-mail endpoint is reachable by unauthenticated users with no capability check, and the email processing path removes WordPress's kses output filters before saving raw markup, allowing the unescaped href attribute value to be stored as post content.
Published: 2026-10-28
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Unauthenticated Stored XSS
Action: Apply Patch
AI Analysis

Impact

Postie, a WordPress email plugin, is vulnerable to a stored cross‑site scripting flaw in all releases through 1.9.87. The flaw originates from the automatic conversion of URLs in email bodies into hyperlinks without sufficient sanitization or escaping. When an email is processed, the plugin removes WordPress’s built‑in KSES output filters and writes the raw, potentially malicious HTML into post content. As a result, an unauthenticated user can embed any JavaScript code in the body of an email, which will be stored and rendered in subsequent visitor pages.

Affected Systems

The affected product is the WordPress Postie plugin, vendor Wayne Allen (product code wayneallen-1). All versions up to and including 1.9.87 are vulnerable. WordPress site administrators who rely on these plugin versions should verify the current deployment and plan an upgrade or patch.

Risk and Exploitability

The CVSS score for this issue is 5.4, indicating a moderate risk. No EPSS score is available and the vulnerability is not listed in CISA’s KEV catalog. Exploitation requires only unauthenticated access to the /?postie=get-mail endpoint, which performs no capability check. Once a malicious email is submitted, the stored XSS payload will execute in the browsers of any user who views the resulting post, potentially allowing credential theft, session hijacking, or defacement.

Generated by OpenCVE AI on October 28, 2026 at 08:24 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Postie plugin to version 1.9.88 or newer, which contains the necessary sanitization fixes.
  • If an immediate update is not possible, restrict access to the postie/get-mail endpoint so that only authenticated users with appropriate capabilities can invoke it.
  • Configure a web application firewall or use content security policies to strip or block embedded script tags from processed email content until a plugin update can be applied.

Generated by OpenCVE AI on October 28, 2026 at 08:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Postie plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Email Body URL Autolink in all versions up to, and including, 1.9.87 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the ?postie=get-mail endpoint is reachable by unauthenticated users with no capability check, and the email processing path removes WordPress's kses output filters before saving raw markup, allowing the unescaped href attribute value to be stored as post content.
Title Postie <= 1.9.87 - Unauthenticated Stored Cross-Site Scripting via Email Body URL Autolink
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:12.519Z

Reserved: 2026-09-25T13:23:48.400Z

Link: CVE-2026-100175

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:42.883

Modified: 2026-10-28T07:16:42.883

Link: CVE-2026-100175

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')