Impact
IBM Langflow OSS 1.0.0 through 1.12.2 contain an insufficiently protected credential flaw that permits a remote authenticated attacker to read protected data, compromising confidentiality. The weakness is mapped to CWE‑522. The attacker must first authenticate, after which the vulnerable application can expose sensitive information.
Affected Systems
The affected product is IBM Langflow OSS, with all releases from 1.0.0 up to and including 1.12.2 vulnerable. IBM recommends upgrading to 1.12.3, which contains the fix.
Risk and Exploitability
The CVSS score of 7.7 indicates a high severity risk. No EPSS score is provided, so exploitation likelihood is indeterminate, and the vulnerability is not listed in the CISA KEV catalog. The attack vector is remote authenticated; an authenticated user can leverage the flaw to obtain stored credentials.
OpenCVE Enrichment