Description
The Hyyan WooCommerce Polylang Integration plugin for WordPress is vulnerable to SQL Injection via the 'variation_ids' parameter of the 'woocommerce_remove_variations' AJAX action in versions up to, and including, 1.5.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2026-10-14
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Unauthorized database query execution leading to potential data exposure
Action: Apply Patch
AI Analysis

Impact

This vulnerability allows an authenticated user with Subscriber-level access or higher to inject arbitrary SQL through the 'variation_ids' parameter of the 'woocommerce_remove_variations' AJAX action. The code fails to properly escape the user-supplied input and the SQL query is not adequately prepared, enabling an attacker to append additional statements. The outcome is the potential extraction of sensitive information from the WordPress database, which undermines confidentiality.

Affected Systems

All installations of the Hyyan WooCommerce Polylang Integration plugin for WordPress with versions up to and including 1.5.0 are affected. Users should check their installed version against vendor release notes to determine impact.

Risk and Exploitability

The CVSS score of 6.5 indicates a moderate severity vulnerability. The EPSS score of less than 1% suggests that active exploitation is unlikely at this time, and the vulnerability is not listed in CISA’s KEV catalog. Attack requires an authenticated user with Subscriber-level access to invoke the vulnerable AJAX endpoint, which can be done remotely from the site’s web interface. Once triggered, injected SQL can read arbitrary tables, potentially exposing user data, order histories, or other sensitive information. The requirement for authentication limits exploitation to existing site users, but the breadth of data at risk warrants high vigilance.

Generated by OpenCVE AI on October 16, 2026 at 01:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the plugin to the latest available release, which contains a patch for this SQL injection vulnerability
  • If an update is not yet available, restrict the 'woocommerce_remove_variations' AJAX action to administrator roles only by adding a capability check or disabling the endpoint for Subscriber-level users
  • Sanitize and validate the 'variation_ids' input server-side using prepared statements or proper escaping to prevent arbitrary SQL injection

Generated by OpenCVE AI on October 16, 2026 at 01:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 04:45:00 +0000

Type Values Removed Values Added
Description The Hyyan WooCommerce Polylang Integration plugin for WordPress is vulnerable to SQL Injection via the 'variation_ids' parameter of the 'woocommerce_remove_variations' AJAX action in versions up to, and including, 1.5.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Title Hyyan WooCommerce Polylang Integration <= 1.5.0 - Authenticated (Subscriber+) SQL Injection via 'variation_ids' Parameter
Weaknesses CWE-89
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T15:09:32.943Z

Reserved: 2026-09-28T16:04:16.863Z

Link: CVE-2026-101926

cve-icon Vulnrichment

Updated: 2026-10-14T16:11:35.271Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T05:16:42.210

Modified: 2026-10-15T16:17:32.210

Link: CVE-2026-101926

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T01:15:15Z

Weaknesses
  • CWE-89

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')