Description
Improper Control of Generation of Code ('Code Injection') vulnerability in WPMU DEV Broken Link Checker broken-link-checker allows Code Injection.This issue affects Broken Link Checker: from n/a through 2.4.14.1.
Published: 2026-10-15
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Code Injection with potential remote code execution
Action: Update Plugin
AI Analysis

Impact

The WPMU DEV Broken Link Checker plugin contains an improper control of code generation vulnerability that allows attackers to inject arbitrary code into the WordPress site. This flaw can let a malicious actor execute locally‑crafted payloads or hijack site functionality, thereby compromising the confidentiality, integrity, or availability of the affected site.

Affected Systems

WordPress installations that have the Broken Link Checker plugin installed in any version up to and including 2.4.14.1 are affected. The vulnerability is present in all revisions from the earliest available release through 2.4.14.1.

Risk and Exploitability

The CVSS score of 6.5 classifies the vulnerability as medium severity, and the EPSS score of < 1 % indicates a low probability of widespread exploitation at present. The plugin is not listed in CISA's KEV catalog. Based on the description, the likely attack vector would involve an authenticated WordPress administrator or another user with permission to configure the plugin, as the injection is performed via the plugin's code generation mechanisms. The vulnerability is not noted as remote code execution by default, but the ability to inject arbitrary code raises the risk of complete site compromise.

Generated by OpenCVE AI on October 16, 2026 at 21:15 UTC.

Remediation

Vendor Solution

Update the WordPress Broken Link Checker plugin to the latest available version (at least 2.4.15).


OpenCVE Recommended Actions

  • Upgrade the Broken Link Checker plugin to version 2.4.15 or later.
  • If an upgrade is not immediately possible, disable or uninstall the plugin to prevent the injection path.
  • Review and harden WordPress site permissions, ensuring only trusted administrators can edit plugin settings.

Generated by OpenCVE AI on October 16, 2026 at 21:15 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 17 Oct 2026 00:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 15 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Description Improper Control of Generation of Code ('Code Injection') vulnerability in WPMU DEV Broken Link Checker broken-link-checker allows Code Injection.This issue affects Broken Link Checker: from n/a through 2.4.14.1.
Title WordPress Broken Link Checker plugin <= 2.4.14.1 - Content Injection vulnerability
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-15T16:41:33.903Z

Reserved: 2026-09-29T00:15:56.342Z

Link: CVE-2026-102389

cve-icon Vulnrichment

Updated: 2026-10-15T14:34:51.688Z

cve-icon NVD

Status : Deferred

Published: 2026-10-15T13:17:10.470

Modified: 2026-10-15T15:17:18.567

Link: CVE-2026-102389

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T21:30:14Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')