Description
The The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.8.19 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires an administrator to have configured an ad block containing a dynamic tag such as {title}, {tag}, {category}, or {smart-tag} with display enabled on search pages, which is a normal and documented plugin configuration.
Published: 2026-10-30
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Arbitrary Shortcode Execution leading to code execution
Action: Apply Patch
AI Analysis

Impact

The Ad Inserter WordPress plugin version 2.8.19 and earlier contains a validation flaw that allows an unauthenticated attacker to trigger the internal do_shortcode routine with arbitrary parameters. The flaw originates when the plugin processes the 's' search parameter without proper sanitization, permitting the injection of any shortcode payload. Because shortcodes can contain executable PHP, successful exploitation effectively grants the attacker the ability to run arbitrary code on the site, which can compromise confidentiality, integrity, and availability. This vulnerability is classified as CWE‑94.

Affected Systems

This flaw affects WordPress installations that include the Ad Inserter – Ad Manager & AdSense Ads plugin with a version of 2.8.19 or earlier. The vulnerability is exploitable only when an administrator has configured an ad block that contains a dynamic tag such as {title}, {tag}, {category}, or {smart-tag} and has that ad block enabled on search pages – a configuration that is commonly used in practice. Sites that have removed or upgraded the plugin, or that never used these dynamic tags on search pages, are not impacted.

Risk and Exploitability

The CVSS score of 6.5 represents medium severity, reflecting an unauthenticated attack with significant impact if the attacker can influence shortcode execution. No EPSS score is available to gauge real‑world exploitation frequency. The vulnerability is not listed in the CISA KEV catalog, indicating that no widespread exploitation has been reported. Attackers would attempt to hit a site's search page, leveraging the search parameter to inject the malicious shortcode. Because no credentials are required, the risk persists until the plugin is patched or the vulnerable configuration is removed.

Generated by OpenCVE AI on October 30, 2026 at 18:52 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Ad Inserter plugin to a version newer than 2.8.19.
  • If upgrading is delayed, remove or disable dynamic tags such as {title}, {tag}, {category}, or {smart-tag} from ad blocks displayed on search pages.
  • Restrict search‑page access for non‑authenticated users and monitor site logs for unexpected shortcode execution.

Generated by OpenCVE AI on October 30, 2026 at 18:52 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
First Time appeared Spacetime
Spacetime ad Inserter – Ad Manager & Adsense Ads
Wordpress-extensions
Wordpress-extensions ad Inserter
Vendors & Products Spacetime
Spacetime ad Inserter – Ad Manager & Adsense Ads
Wordpress-extensions
Wordpress-extensions ad Inserter

Fri, 30 Oct 2026 18:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.8.19 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires an administrator to have configured an ad block containing a dynamic tag such as {title}, {tag}, {category}, or {smart-tag} with display enabled on search pages, which is a normal and documented plugin configuration.
Title Ad Inserter <= 2.8.19 - Unauthenticated Arbitrary Shortcode Execution via 's' Search Parameter
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'}


Subscriptions

Spacetime Ad Inserter – Ad Manager & Adsense Ads
Wordpress-extensions Ad Inserter
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T17:24:48.214Z

Reserved: 2026-09-29T17:36:54.940Z

Link: CVE-2026-102905

cve-icon Vulnrichment

Updated: 2026-10-30T17:24:44.230Z

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:17:14.540

Modified: 2026-10-30T18:33:26.087

Link: CVE-2026-102905

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T19:15:16Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')