Description
The Redux Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 4.5.15 via the multi_media field. This is due to the field's renderer printing the stored value into an href attribute, a hidden input value and an HTML element without escaping, while every neighbouring attribute in the same method is wrapped in esc_attr(). It is compounded by Redux_Extension_Users::user_meta_save() evaluating a field's 'permissions' requirement against a user id taken from the request body ('checkuser_id') rather than the current user, so a Subscriber can write a field declared for 'manage_options'. This makes it possible for authenticated attackers with Subscriber-level access and above to inject arbitrary web scripts into their own profile record that execute when an administrator views that user's profile in the dashboard. Requires a theme or plugin that registers a multi_media field through the Redux Users API.
Published: 2026-10-30
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored XSS script execution
Action: Patch
AI Analysis

Impact

A stored cross‑site scripting flaw exists in the Redux Framework WordPress plugin, specifically in the multi_media field renderer. The renderer injects user input into an href attribute, a hidden input and an HTML element without escaping, while surrounding attributes are escaped. Coupled with a permission check that mistakenly uses a request‑supplied user id (checkuser_id) instead of the current user, a Subscriber‑level or higher user can supply malicious scripts that are stored in the profile. When an administrator views that profile in the dashboard, the script runs in the admin context, enabling the attacker to execute arbitrary code. This stored XSS vulnerability corresponds to CWE‑79.

Affected Systems

All releases of the Redux Framework plugin by davidanderson, version 4.5.15 and earlier, are vulnerable when installed as a WordPress plugin, provided that a theme or plugin registers at least one multi_media field via the Redux Users API. Sites running Redux Framework 4.5.16 or later are not affected.

Risk and Exploitability

The CVSS v3.1 score of 6.4 indicates moderate severity. Exploitation requires only an authenticated account with Subscriber or higher role. The attacker can store a payload that will be executed when an administrator inspects the profile, effectively granting script execution in the admin interface. No EPSS data is available and the vulnerability is not listed in CISA’s KEV catalog, yet the straightforward authentication prerequisite means the risk is significant for affected WordPress installations.

Generated by OpenCVE AI on October 30, 2026 at 18:51 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Redux Framework to version 4.5.16 or later, which fixes the rendering logic and corrects the permission check.
  • If an immediate upgrade is not feasible, temporarily remove or disable all multi_media fields registered through the Redux Users API to eliminate the injection vector.
  • If the Redux Framework plugin is not essential, uninstall it from the WordPress installation.
  • Ensure that any custom code registering multi_media fields performs proper escaping or restricts such fields to users with higher privileges than Subscriber.

Generated by OpenCVE AI on October 30, 2026 at 18:51 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 20:15:00 +0000

Type Values Removed Values Added
First Time appeared Davidanderson
Davidanderson redux Framework
Wordpress-extensions
Wordpress-extensions redux Framework
Vendors & Products Davidanderson
Davidanderson redux Framework
Wordpress-extensions
Wordpress-extensions redux Framework

Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The Redux Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 4.5.15 via the multi_media field. This is due to the field's renderer printing the stored value into an href attribute, a hidden input value and an HTML element without escaping, while every neighbouring attribute in the same method is wrapped in esc_attr(). It is compounded by Redux_Extension_Users::user_meta_save() evaluating a field's 'permissions' requirement against a user id taken from the request body ('checkuser_id') rather than the current user, so a Subscriber can write a field declared for 'manage_options'. This makes it possible for authenticated attackers with Subscriber-level access and above to inject arbitrary web scripts into their own profile record that execute when an administrator views that user's profile in the dashboard. Requires a theme or plugin that registers a multi_media field through the Redux Users API.
Title Redux Framework <= 4.5.15 - Authenticated (Subscriber+) Stored Cross-Site Scripting via multi_media Field and Client-Supplied checkuser_id
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

Davidanderson Redux Framework
Wordpress-extensions Redux Framework
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T18:08:58.237Z

Reserved: 2026-09-29T19:07:43.153Z

Link: CVE-2026-102918

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:17:14.690

Modified: 2026-10-30T19:17:51.883

Link: CVE-2026-102918

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T20:00:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')