Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpmet ElementsKit Elementor addons Lite elementskit-lite allows Stored XSS.This issue affects ElementsKit Elementor addons Lite: from n/a through 4.0.6.
Published: 2026-10-01
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch Plugin
AI Analysis

Impact

The vulnerability permits the insertion of arbitrary client‑side code that is stored and later served to visitors. An attacker could use this to steal session cookies, deface the site, or redirect users to malicious domains, thereby compromising confidentiality, integrity, and user trust.

Affected Systems

WordPress ElementsKit Elementor addons Lite plugin versions 4.0.6 and all older releases are affected. Versions 4.0.7 and newer contain the fix.

Risk and Exploitability

The CVSS score of 6.5 indicates a moderate severity vulnerability. No EPSS score is available and the issue is not listed in CISA's KEV catalog. Exploitation requires the ability to submit input that the plugin stores and later renders without proper neutralization, which could be achieved through an authenticated or unauthenticated content submission path, depending on site configuration.

Generated by OpenCVE AI on October 1, 2026 at 14:59 UTC.

Remediation

Vendor Solution

Update the WordPress ElementsKit Elementor addons Lite plugin to the latest available version (at least 4.0.7).


OpenCVE Recommended Actions

  • Update the ElementsKit Elementor addons Lite plugin to version 4.0.7 or later.
  • Ensure that WordPress core, themes, and all other plugins are also kept up to date with the latest security releases.
  • Enforce strict input validation and output escaping on all user‑generated content to mitigate future injection attacks, in line with CWE‑79 best practices.

Generated by OpenCVE AI on October 1, 2026 at 14:59 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 01 Oct 2026 20:00:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions elementskit Elementor Addons Lite
Wpmet
Wpmet elementskit Elementor Addons
Vendors & Products Wordpress-extensions
Wordpress-extensions elementskit Elementor Addons Lite
Wpmet
Wpmet elementskit Elementor Addons

Thu, 01 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 01 Oct 2026 13:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpmet ElementsKit Elementor addons Lite elementskit-lite allows Stored XSS.This issue affects ElementsKit Elementor addons Lite: from n/a through 4.0.6.
Title WordPress ElementsKit Elementor addons Lite plugin <= 4.0.6 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Wordpress-extensions Elementskit Elementor Addons Lite
Wpmet Elementskit Elementor Addons
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-01T13:17:59.844Z

Reserved: 2026-09-30T00:15:58.644Z

Link: CVE-2026-103063

cve-icon Vulnrichment

Updated: 2026-10-01T13:17:56.272Z

cve-icon NVD

Status : Deferred

Published: 2026-10-01T13:17:07.960

Modified: 2026-10-01T14:34:35.357

Link: CVE-2026-103063

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-01T19:34:36Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')