Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpmet ElementsKit Elementor addons Lite elementskit-lite allows Stored XSS.This issue affects ElementsKit Elementor addons Lite: from n/a through 4.0.6.
Published: 2026-10-01
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Now
AI Analysis

Impact

Improper neutralization of user input during web page generation in the WordPress plugin ElementsKit Elementor addons Lite leads to stored cross‑site scripting. The flaw allows an attacker to embed malicious JavaScript that will execute in the browser of any visitor who loads a page where the plugin renders affected content. This capability can result in cookie theft, session hijacking, site defacement, or delivery of additional malware, thereby compromising the confidentiality, integrity, and availability of the WordPress installation. Based on the description, it is inferred that the vulnerability is triggered by any input that the plugin accepts for rendering, such as post titles, widget content, or other editable fields provided by the add‑ons Lite package.

Affected Systems

The affected product is the ElementsKit Elementor addons Lite plugin for WordPress, supplied by Wpmet. Versions up to and including 4.0.6 are impacted; earlier releases are not specifically mentioned, so the assumption is that the vulnerability exists from the first released version through 4.0.6. Any WordPress site that installs any of these versions is vulnerable. The vulnerability is independent of site configuration, as the flaw resides in a core component of the add‑ons Lite package.

Risk and Exploitability

The CVSS score of 6.5 classifies the vulnerability as moderate severity. The EPSS score is not available, so the exact exploitation likelihood remains undefined. The vulnerability is not listed in CISA’s KEV catalog, indicating no known widespread exploitation at this time. Nevertheless, stored XSS can be triggered by ordinary site users who create or edit content through the plugin’s interfaces, suggesting that the required attack conditions are readily available to anyone with editor or administrator privileges. Therefore, the risk remains significant until the vendor’s patch is applied.

Generated by OpenCVE AI on October 1, 2026 at 15:33 UTC.

Remediation

Vendor Solution

Update the WordPress ElementsKit Elementor addons Lite plugin to the latest available version (at least 4.0.7).


OpenCVE Recommended Actions

  • Update the ElementsKit Elementor addons Lite plugin to the latest version (4.0.7 or newer) as released by Wpmet.
  • If update cannot be performed immediately, temporarily disable or delete the plugin to eliminate the vulnerable code path.
  • Inspect existing content rendered by the plugin and manually remove or escape any scripts that may have already been injected, especially in custom post types, widget areas, or shortcodes.

Generated by OpenCVE AI on October 1, 2026 at 15:33 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 01 Oct 2026 16:00:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions elementskit Elementor Addons Lite
Wpmet
Wpmet elementskit Elementor Addons
Vendors & Products Wordpress-extensions
Wordpress-extensions elementskit Elementor Addons Lite
Wpmet
Wpmet elementskit Elementor Addons

Thu, 01 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 01 Oct 2026 13:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpmet ElementsKit Elementor addons Lite elementskit-lite allows Stored XSS.This issue affects ElementsKit Elementor addons Lite: from n/a through 4.0.6.
Title WordPress ElementsKit Elementor addons Lite plugin <= 4.0.6 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Wordpress-extensions Elementskit Elementor Addons Lite
Wpmet Elementskit Elementor Addons
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-01T13:52:30.520Z

Reserved: 2026-09-30T00:15:58.644Z

Link: CVE-2026-103064

cve-icon Vulnrichment

Updated: 2026-10-01T13:52:26.691Z

cve-icon NVD

Status : Deferred

Published: 2026-10-01T13:17:08.090

Modified: 2026-10-01T14:34:35.357

Link: CVE-2026-103064

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-01T15:45:08Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')