Description
The Prenotazioni WordPress plugin through 1.7.5 does not have authorisation and CSRF checks when saving its settings, and does not escape some of them when outputting them, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks against administrators and site visitors.
Published: 2026-10-11
Score: 8.8 High
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

The Prenotazioni WordPress plugin allows an unauthenticated user to update plugin settings without authorization or CSRF protection. The plugin fails to escape certain setting values when displaying them, creating a stored XSS vector that can be used to inject arbitrary script into pages viewed by administrators and site visitors. This flaw enables attackers to compromise user browsers, steal credentials, or deface content.

Affected Systems

WordPress sites that install the Prenotazioni plugin at or before version 1.7.5. The vulnerability is tied to the plugin itself and affects all installed WordPress sites that are running these or older releases.

Risk and Exploitability

Because no authentication is required, the attack can be carried out by any external actor who can send a crafted request to the site. While the CVSS score is 8.8 and EPSS is unavailable, the vulnerability is not listed in KEV; nevertheless, the zero‑auth requirement and persistent nature of the stored payload give this flaw a high attack potential. An attacker can insert scripts that run in the browsers of site administrators or any visitor, leading to potential credential theft, session hijacking, or malicious content delivery. The lack of proper authorization checks also means that the attacker can repeatedly modify the stored values to maintain persistence.

Generated by OpenCVE AI on October 11, 2026 at 14:07 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Prenotazioni plugin to the most recent version that addresses this flaw.
  • If an immediate upgrade is not feasible, disable or delete the plugin until a fix is available, preventing unauthenticated update access.
  • Apply general WordPress hardening measures: enforce strong user permissions, keep WordPress core and all plugins up to date, and employ a reputable security plugin that blocks XSS and limits account capabilities.

Generated by OpenCVE AI on October 11, 2026 at 14:07 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Sun, 11 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Weaknesses CWE-285
CWE-352
CWE-79

Sun, 11 Oct 2026 06:30:00 +0000

Type Values Removed Values Added
Description The Prenotazioni WordPress plugin through 1.7.5 does not have authorisation and CSRF checks when saving its settings, and does not escape some of them when outputting them, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks against administrators and site visitors.
Title Prenotazioni <= 1.7.5 - Unauthenticated Stored XSS via Settings Update
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-11T11:42:53.757Z

Reserved: 2026-09-30T11:32:48.411Z

Link: CVE-2026-103305

cve-icon Vulnrichment

Updated: 2026-10-11T11:29:55.701Z

cve-icon NVD

Status : Deferred

Published: 2026-10-11T07:17:21.007

Modified: 2026-10-13T20:36:00.850

Link: CVE-2026-103305

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-11T14:15:18Z

Weaknesses
  • CWE-285

    Improper Authorization

  • CWE-352

    Cross-Site Request Forgery (CSRF)

  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')