Description
The GPTranslate WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.
Published: 2026-10-08
Score: 7.5 High
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting via unauthenticated REST API
Action: Immediate Patch
AI Analysis

Impact

The GPTranslate WordPress plugin, prior to version 2.34.14, fails to enforce access control on its REST API endpoints that allow translation storage. Attackers can submit arbitrary translation data that is later reflected on translated pages without proper escaping, granting them stored Cross‑Site Scripting capabilities. Successful exploitation can lead to theft of user credentials, session hijacking, or defacement of sites rendered with those translations.

Affected Systems

The vulnerability affects all installations of the GPTranslate WordPress plugin older than 2.34.14. No specific WordPress core versions are mentioned, so any site running the plugin before the patched release is at risk.

Risk and Exploitability

The CVSS score of 7.5 indicates high severity, but the unavailability of EPSS data makes precise quantitative risk assessment difficult. The vulnerability is not listed in CISA KEV, indicating no known exploit activity at this time. The likely attack vector is web-based, requiring only that an attacker can reach the plugin’s REST API and that the site renders translations server‑side.

Generated by OpenCVE AI on October 8, 2026 at 12:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade GPTranslate to version 2.34.14 or later to eliminate the vulnerability.
  • If an upgrade is not immediately possible, disable server‑side translation storage or block the REST API endpoints used for storing translations.
  • Apply a Content‑Security‑Policy that restricts the execution of scripts to trusted origins, and ensure your web application firewall blocks suspicious XSS payloads.

Generated by OpenCVE AI on October 8, 2026 at 12:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 09 Oct 2026 09:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions gptranslate
Vendors & Products Wordpress-extensions
Wordpress-extensions gptranslate

Thu, 08 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Thu, 08 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Weaknesses CWE-284
CWE-79

Thu, 08 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The GPTranslate WordPress plugin before 2.34.14 does not properly restrict who can store translations, and does not escape them when outputting them in translated pages, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks when server-side translations are enabled.
Title GPTranslate < 2.34.14 - Unauthenticated Stored XSS via REST API Translation Storage
References

Subscriptions

Wordpress-extensions Gptranslate
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-08T10:59:19.907Z

Reserved: 2026-09-30T11:35:59.238Z

Link: CVE-2026-103309

cve-icon Vulnrichment

Updated: 2026-10-08T10:57:15.435Z

cve-icon NVD

Status : Deferred

Published: 2026-10-08T06:16:37.287

Modified: 2026-10-08T20:51:18.123

Link: CVE-2026-103309

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T08:13:40Z

Weaknesses
  • CWE-284

    Improper Access Control

  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')