Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP ManageNinja LLC FluentForm fluentform allows Stored XSS.This issue affects FluentForm: from n/a through 6.2.14.
Published: 2026-10-01
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch
AI Analysis

Impact

The vulnerability is a stored Cross‑Site Scripting flaw caused by the FluentForm plugin's failure to properly neutralize user‑supplied input. Exploitation allows an attacker to inject JavaScript that executes when other users load a page that displays the stored data. This can lead to cookie theft, session hijacking, defacement or phishing attacks. The issue does not provide direct code execution on the server, but it can compromise confidentiality and integrity of user data for site visitors. The weakness is identified as CWE‑79.

Affected Systems

FluentForm, a WordPress contact and form building plugin developed by WP ManageNinja LLC, is vulnerable in all releases up to and including version 6.2.14. The fix is available in version 6.2.15 and later. Administrators of sites that use any affected FluentForm installation should verify the plugin version and plan an upgrade.

Risk and Exploitability

The CVSS score of 6.5 reflects a moderate impact. EPSS is not available, so the likelihood of exploitation is currently unknown, though the vulnerability is common enough to be of concern. It is not listed in CISA's KEV catalog, indicating no confirmed widespread exploitation. Exploitation requires the attacker to be able to submit or modify form content that is rendered without proper sanitization, typically through a user‑visible form or via an admin user. Because the injected code runs in the context of site visitors, any user who views form pages could be affected.

Generated by OpenCVE AI on October 1, 2026 at 15:00 UTC.

Remediation

Vendor Solution

Update the WordPress FluentForm plugin to the latest available version (at least 6.2.15).


OpenCVE Recommended Actions

  • Update the FluentForm plugin to version 6.2.15 or later to remove the stored XSS flaw.
  • After upgrading, review any forms that contained custom data for potential malicious content and recreate them if needed to ensure no residual scripts survive.
  • Until the upgrade can be performed, limit access to the affected forms or disable them to prevent untrusted input from being stored.

Generated by OpenCVE AI on October 1, 2026 at 15:00 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 01 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 01 Oct 2026 13:00:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP ManageNinja LLC FluentForm fluentform allows Stored XSS.This issue affects FluentForm: from n/a through 6.2.14.
Title WordPress FluentForm plugin <= 6.2.14 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-01T13:18:56.897Z

Reserved: 2026-09-30T12:43:33.093Z

Link: CVE-2026-103343

cve-icon Vulnrichment

Updated: 2026-10-01T13:18:53.062Z

cve-icon NVD

Status : Deferred

Published: 2026-10-01T13:17:08.883

Modified: 2026-10-01T14:34:35.357

Link: CVE-2026-103343

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-01T15:15:10Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')