Description
The Social Share Buttons & Analytics Plugin – GetSocial.io plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'response' parameter in all versions up to, and including, 4.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload is stored in the gs-alert-msg, gs-alert-utm, and gs-alert-cta WordPress options and executes in an administrator's browser when the GetSocial settings page is visited.
Published: 2026-10-14
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting affecting administrator browsers
Action: Apply Patch
AI Analysis

Impact

The GetSocial.io Social Share Buttons & Analytics Plugin contains a stored cross‑site scripting flaw that enables authenticated users with subscriber-level access or higher to inject arbitrary JavaScript via the ‘response’ parameter. The injected script is saved in WordPress options—gs‑alert‑msg, gs‑alert‑utm, and gs‑alert‑cta—and is executed when an administrator visits the GetSocial settings page. This flaw allows the attacker to run client‑side code in the context of the site’s administrators, potentially compromising the functionality of the admin interface.

Affected Systems

WordPress installations that use the Social Share Buttons & Analytics Plugin – GetSocial.io, version 4.5 or earlier, are affected. The vulnerability resides in the plugin’s handling of the gs_update_with_values AJAX request, which is accessible to any authenticated user with subscriber or higher permission.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity. The EPSS score is below 1 %, reflecting a very low probability of active exploitation. The vulnerability is not listed in CISA’s KEV catalog. Exploitation requires valid credentials of an authenticated subscriber‑level or higher user to submit a malicious payload via the AJAX endpoint; once injected, the script executes whenever an administrator opens the plugin settings page, with no additional conditions cited in the disclosure.

Generated by OpenCVE AI on October 16, 2026 at 01:06 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the plugin to a version newer than 4.5 or apply the vendor’s official patch if available.
  • Sanitize or delete the stored options gs‑alert‑msg, gs‑alert‑utm, and gs‑alert‑cta from the WordPress database to remove any injected scripts.
  • Restrict subscriber‑level users from editing plugin settings or reduce their privileges so that only trusted administrators have access to the plugin configuration.

Generated by OpenCVE AI on October 16, 2026 at 01:06 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 14 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 04:45:00 +0000

Type Values Removed Values Added
Description The Social Share Buttons & Analytics Plugin – GetSocial.io plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'response' parameter in all versions up to, and including, 4.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload is stored in the gs-alert-msg, gs-alert-utm, and gs-alert-cta WordPress options and executes in an administrator's browser when the GetSocial settings page is visited.
Title Social Share Buttons & Analytics Plugin <= 4.5 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'response' Parameter via gs_update_with_values AJAX
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-14T14:22:44.025Z

Reserved: 2026-09-30T13:01:45.673Z

Link: CVE-2026-103369

cve-icon Vulnrichment

Updated: 2026-10-14T14:22:40.602Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T05:16:42.340

Modified: 2026-10-14T15:17:03.837

Link: CVE-2026-103369

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T01:15:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')