Description
The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpas_files' parameter in all versions up to, and including, 6.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the "Enable drag-n-drop uploader for ticket form" setting is enabled, as it is disabled by default.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch immediately
AI Analysis

Impact

The Awesome Support plugin allows a stored cross‑site scripting vulnerability through the 'wpas_files' parameter when the drag‑n‑drop uploader is enabled, due to insufficient input sanitization and output escaping. This flaw enables an attacker who is able to authenticate to WordPress with custom‑level access or higher to inject and persist arbitrary JavaScript in pages accessed by other users. The injected script runs in the context of the victim’s session, potentially allowing credential theft, session hijacking, or defacement. This issue is a classic example of improper input validation (CWE‑79).

Affected Systems

Affected systems include the Awesome Support – WordPress HelpDesk & Support Plugin for WordPress across all releases up to and including version 6.4.1. The vulnerability applies only when the setting 'Enable drag‑n‑drop uploader for ticket form' is turned on, a feature that is disabled by default. Administrators who grant custom‑level role permissions to users are therefore at higher risk. Ensuring the plugin is upgraded to a patched version or removing the feature from their configuration mitigates the problem.

Risk and Exploitability

The CVSS v3 score is 6.4, indicating a medium severity vulnerability. EPSS is not available for this entry, and the vulnerability is not listed in the CISA KEV catalog. Because the flaw requires authenticated access, the likelihood of exploitation is limited to users with at least custom‑level permissions, making the overall risk moderate. No publicly disclosed exploits are known at this time, but the potential impact of a successful injection warrants prompt action.

Generated by OpenCVE AI on October 28, 2026 at 08:28 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Awesome Support to the latest stable release (currently 6.4.2 or newer) which removes the faulty handling of the 'wpas_files' parameter.
  • If an immediate upgrade is not possible, disable the 'Enable drag‑n‑drop uploader for ticket form' setting to prevent the MIME confusion path.
  • Review user role assignments and restrict custom‑level or higher permissions to only trusted personnel.

Generated by OpenCVE AI on October 28, 2026 at 08:28 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpas_files' parameter in all versions up to, and including, 6.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the "Enable drag-n-drop uploader for ticket form" setting is enabled, as it is disabled by default.
Title Awesome Support <= 6.4.1 - Authenticated (Custom+) Stored Cross-Site Scripting via Ticket Attachment MIME Confusion
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:05.565Z

Reserved: 2026-09-30T13:01:53.277Z

Link: CVE-2026-103370

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:43.070

Modified: 2026-10-28T07:16:43.070

Link: CVE-2026-103370

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')