Description
The Mintpay for WooCommerce WordPress plugin through 2.2.3 does not verify the authenticity of the payment callback it processes, allowing unauthenticated attackers to mark arbitrary orders as paid, to cancel arbitrary orders, and to disclose order details including customer contact information.
Published: 2026-10-26
Score: n/a
EPSS: n/a
KEV: No
Impact: Unauthenticated order state manipulation and sensitive data disclosure
Action: Immediate Patch
AI Analysis

Impact

The vulnerability arises because Mintpay for WooCommerce processes payment callbacks without verifying their source or integrity. An attacker who can fabricate such callbacks can mark any order as paid, cancel any order, and read order details, including customer contact information. The flaw constitutes a lack of input authentication and authorization, enabling remote denial of service within the ordering subsystem and the exfiltration of customer data. The impact spans confidentiality, integrity, and availability of the e‑commerce system, potentially exposing personally identifiable information and disrupting business operations.

Affected Systems

WordPress plugin Mintpay for WooCommerce of version 2.2.3 and earlier is affected. The plugin is used to handle payment processing for WooCommerce shops; no further version granularity is available in the public data.

Risk and Exploitability

The flaw is a remote exploitation scenario that requires the attacker to send a forged callback to the plugin. Because the plugin does not authenticate the callback, no prior access or credentials are needed. The CVSS score is high due to this lack of authentication, but no EPSS score is provided. The vulnerability is not listed in the CISA KEV catalog, suggesting it is currently unexploited or not widely tracked, yet the potential for mass disclosure or business compromise remains significant.

Generated by OpenCVE AI on October 26, 2026 at 07:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the latest Mintpay plugin version 2.2.4 or later which validates payment callbacks
  • Restrict the callback endpoint to accept requests only from trusted payment gateway IPs or enforce HMAC signatures
  • Disable or monitor the payment callback URL if an upgrade cannot be applied immediately

Generated by OpenCVE AI on October 26, 2026 at 07:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 26 Oct 2026 06:30:00 +0000

Type Values Removed Values Added
Description The Mintpay for WooCommerce WordPress plugin through 2.2.3 does not verify the authenticity of the payment callback it processes, allowing unauthenticated attackers to mark arbitrary orders as paid, to cancel arbitrary orders, and to disclose order details including customer contact information.
Title Mintpay <= 2.2.3 - Unauthenticated Order Payment Completion and Cancellation via Callback Forgery
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-26T06:00:18.388Z

Reserved: 2026-09-30T13:15:11.950Z

Link: CVE-2026-103381

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-26T07:17:07.290

Modified: 2026-10-26T07:17:07.290

Link: CVE-2026-103381

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-26T07:30:08Z

Weaknesses

No weakness.