Description
The Booking Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' parameter in all versions up to, and including, 1.7.29 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-14
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) with authenticated contributor‑level access
Action: Patch Update
AI Analysis

Impact

The Booking Package plugin for WordPress is vulnerable to stored Cross‑Site Scripting via the id parameter in all releases up to and including 1.7.29 due to insufficient input sanitization and output escaping; this flaw allows an authenticated user with contributor‑level privileges or higher to inject arbitrary scripts that run whenever a page containing the injected content is accessed, potentially facilitating session hijacking, defacement, or the execution of malicious code.

Affected Systems

All WordPress sites that employ the Booking Package plugin, developed by masaakitanaka, and running any version up to and including 1.7.29 are affected. Versions 1.7.30 and later are not vulnerable per the vendor’s release notes.

Risk and Exploitability

The vulnerability has a CVSS score of 6.4, indicating moderate severity, and an EPSS score of less than 1% suggesting a low current probability of exploitation. It is not listed in CISA’s KEV catalog. Because exploitation requires authenticated contributor‑level access, it is not a public vulnerability, but the potential impact of script injection on legitimate users and the ease of achieving it once credentials are obtained warrant attention. The likely attack vector is application‑level, leveraging the plugin’s shortcode processing to embed malicious scripts (this inference is drawn from the description of stored XSS via the 'id' attribute). The flaw could be leveraged stealthily with minimal obvious indications of compromise.

Generated by OpenCVE AI on October 16, 2026 at 01:48 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Booking Package plugin to version 1.7.30 or later to remove the stored XSS flaw.
  • If an upgrade cannot be performed immediately, temporarily disable the Booking Package plugin to prevent further exploitation until a patch is applied.
  • As a manual workaround, edit the plugin’s shortcode handler to apply proper HTML encoding to the id attribute or otherwise sanitize user input before rendering.
  • Review WordPress user roles and revoke contributor‑level access to individuals who do not need it, limiting the pool of accounts that can create or edit booking content.

Generated by OpenCVE AI on October 16, 2026 at 01:48 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 01:45:00 +0000

Type Values Removed Values Added
Description The Booking Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' parameter in all versions up to, and including, 1.7.29 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Booking Package <= 1.7.29 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'id' Shortcode Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T15:09:58.126Z

Reserved: 2026-09-30T14:52:25.455Z

Link: CVE-2026-103425

cve-icon Vulnrichment

Updated: 2026-10-14T16:11:39.461Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T02:16:55.793

Modified: 2026-10-15T16:17:32.570

Link: CVE-2026-103425

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T02:00:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')