Description
The Pubjet | پاب‌جت plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 5.4.8. This is due to the `checkToken()` AJAX handler — registered under `wp_ajax_pubjet-check-token` — performing no capability check and no nonce verification before unconditionally writing the attacker-supplied `token` GET parameter directly into the site-wide `pubjet_settings` option via `pubjet_update_setting()`, prior to any remote validation. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the plugin's stored REST API credential with an attacker-chosen value, immediately elevating their effective privileges to those of an authorized Pubjet API client and enabling them to invoke otherwise-restricted endpoints — `createReportage`, `updateReportage`, `deleteReportage`, `toggleCopyright`, and `createBacklink` — to create, modify, and delete arbitrary reportage posts and manipulate plugin state that Subscribers cannot normally access. The privilege escalation is self-reinforcing: because `RestApi::isTokenValid()` authenticates solely by comparing the incoming `Authorization` header against the value returned by `pubjet_token()`, which reads from the same option the unprotected handler writes to, the attacker-planted token is trusted as legitimate on all subsequent requests.
Published: 2026-11-06
Score: 7.6 High
EPSS: n/a
KEV: No
Impact: Privilege Escalation via API Token Overwrite
Action: Immediate Patch
AI Analysis

Impact

The Pubjet plugin contains an AJAX handler that performs no capability check or nonce validation before writing an attacker supplied token into the site‑wide settings. Any authenticated user with Subscriber or higher access can overwrite the stored REST API credential. This elevates the user’s privileges to that of an authorized Pubjet API client, allowing the exploitation of otherwise restricted endpoints to create, modify or delete reportage posts and change plugin state that is normally off‑limits for Subscribers. The flaw is a classic privilege‑escalation vulnerability (CWE‑269).

Affected Systems

WordPress sites running the Pubjet plugin version 5.4.8 or earlier are affected. The vulnerability exists in the Ajax.php and RestApi.php files of that release. Administrators using WordPress should review the plugin version history.

Risk and Exploitability

The CVSS score of 7.6 indicates a high severity. Because the vulnerability requires only the ability to authenticate as a Subscriber or higher, any such user can exploit it. EPSS is not available, and the flaw is not listed in CISA’s KEV catalog, but the lack of capability checks makes exploitation straightforward. Once the attacker plants the token, the RestApi token validation routine will treat it as legitimate on all future requests, creating a self‑reinforcing privilege‑escalation loop.

Generated by OpenCVE AI on November 6, 2026 at 12:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Pubjet plugin to a version newer than 5.4.8, which removes the unprotected token write logic.
  • If an update is not yet available, temporarily disable the ajax action by removing or commenting out the wp_ajax_pubjet-check-token hook in the plugin files or by applying a custom code snippet that blocks the request unless the current user has administrator rights.
  • As a developer, modify the Ajax handler to include proper capability checks (e.g., user_can( 'manage_options' )) and enforce a nonce validation before writing the token value.

Generated by OpenCVE AI on November 6, 2026 at 12:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Pubjet | پاب‌جت plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 5.4.8. This is due to the `checkToken()` AJAX handler — registered under `wp_ajax_pubjet-check-token` — performing no capability check and no nonce verification before unconditionally writing the attacker-supplied `token` GET parameter directly into the site-wide `pubjet_settings` option via `pubjet_update_setting()`, prior to any remote validation. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the plugin's stored REST API credential with an attacker-chosen value, immediately elevating their effective privileges to those of an authorized Pubjet API client and enabling them to invoke otherwise-restricted endpoints — `createReportage`, `updateReportage`, `deleteReportage`, `toggleCopyright`, and `createBacklink` — to create, modify, and delete arbitrary reportage posts and manipulate plugin state that Subscribers cannot normally access. The privilege escalation is self-reinforcing: because `RestApi::isTokenValid()` authenticates solely by comparing the incoming `Authorization` header against the value returned by `pubjet_token()`, which reads from the same option the unprotected handler writes to, the attacker-planted token is trusted as legitimate on all subsequent requests.
Title Pubjet | پاب‌جت <= 5.4.8 - Authenticated (Subscriber+) Privilege Escalation to 'check-token' AJAX Action
Weaknesses CWE-269
References
Metrics cvssV3_1

{'score': 7.6, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T11:17:34.982Z

Reserved: 2026-09-30T16:14:11.363Z

Link: CVE-2026-103479

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:15.440

Modified: 2026-11-06T12:17:15.567

Link: CVE-2026-103479

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T12:30:04Z

Weaknesses
  • CWE-269

    Improper Privilege Management