Description
The The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.1.18. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with custom-level access and above, to execute arbitrary shortcodes. The vulnerable output block is gated by the 'ampforwp-cat-description' setting, which is enabled by default, meaning the vast majority of installations are affected without any additional configuration change.
Published: 2026-11-06
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Arbitrary code execution via shortcode injection
Action: Patch
AI Analysis

Impact

The AMP for WP – Accelerated Mobile Pages plugin allows authenticated attackers with Subscriber level or higher to inject and execute arbitrary shortcodes through the author biographical information field. The vulnerability arises because the plugin does not validate the content before calling WordPress’s do_shortcode function, enabling arbitrary code to run within the WordPress environment. This can be used to read, modify, or delete site content or run other registered shortcode actions that may affect site integrity or availability.

Affected Systems

WordPress sites that have the AMP for WP plugin at version 1.1.18 or earlier. The setting controlling the vulnerable output block, ampforwp-cat-description, is enabled by default, so the majority of deployments of these versions are affected. Attackers need at least Subscriber‑level or custom‑level access to modify the author biographical field; thus users with these roles who are entrusted with write permissions to author profiles can exploit the flaw.

Risk and Exploitability

The CVSS score of 5.4 indicates a medium severity. The EPSS score is not available, so the exact likelihood of exploitation cannot be quantified, but the flaw is not listed in the CISA KEV catalog. The attack vector is an authenticated, in‑site workflow requiring a role with custom‑level or higher access; an attacker would edit a user profile to insert malicious shortcodes into the description field. If the injected shortcode performs dangerous operations, the attacker can achieve full code execution inside the WordPress application, compromising confidentiality, integrity, and availability of the site.

Generated by OpenCVE AI on November 6, 2026 at 12:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the AMP for WP plugin to version 1.1.19 or later to apply the vendor‑supplied fix.
  • If an upgrade is not immediately possible, disable the "ampforwp-cat-description" option so that the vulnerable output block is not rendered, preventing execution of uncontrolled shortcodes.
  • Revoke or restrict the custom‑level role from users who can edit author biographies, limiting the number of users capable of injecting shortcodes.
  • Add content‑sanitization rules or use a security plugin to filter or block shortcode execution for non‑administrative users.

Generated by OpenCVE AI on November 6, 2026 at 12:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.1.18. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with custom-level access and above, to execute arbitrary shortcodes. The vulnerable output block is gated by the 'ampforwp-cat-description' setting, which is enabled by default, meaning the vast majority of installations are affected without any additional configuration change.
Title AMP for WP <= 1.1.18 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via Author Biographical Info
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T11:17:40.974Z

Reserved: 2026-10-01T14:16:26.482Z

Link: CVE-2026-103908

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:15.650

Modified: 2026-11-06T12:17:15.783

Link: CVE-2026-103908

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T13:00:07Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')