Description
The User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'field_attr[required]' parameter in all versions up to, and including, 4.3.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The nonce check on the wpuf_get_child_cat AJAX action is not an effective security barrier because the wpuf_nonce value is publicly localized to every anonymous visitor of any page containing a WPUF shortcode, making it freely harvestable by an unauthenticated attacker.
Published: 2026-10-31
Score: 6.1 Medium
EPSS: n/a
KEV: No
Impact: Reflected Cross-Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The WordPress plugin User Frontend is vulnerable to a reflected XSS flaw that arises from the lack of input sanitization and output escaping on the 'field_attr[required]' parameter. Attackers can inject arbitrary scripts into pages that are rendered when a victim interacts with content crafted by the attacker, such as clicking a link. This vulnerability permits unauthenticated attackers to execute code in the context of the victim’s browser, potentially enabling session hijacking, data theft or further phishing attacks.

Affected Systems

The flaw affects all published releases of the User Frontend plugin up to and including version 4.3.13. The vulnerability is present in the base plugin and all its subsystem components, including membership, registration, profile, directory and content restriction modules supplied by Wedevs for WordPress.

Risk and Exploitability

The vulnerability scores a CVSS base of 6.1, reflecting moderate impact and ease of exploitation. EPSS data is not available, and the flaw is not listed in CISA KEV. The attack requires only that an unauthenticated user be able to reach a page containing a User Frontend shortcode containing the vulnerable parameter; the nonce mechanism is ineffective because it is publicly accessible. Given that the vulnerability can be triggered from any external link, the risk to sites hosting the vulnerable plugin is high; a single malicious URL could compromise any unsuspecting user who visits it.

Generated by OpenCVE AI on October 31, 2026 at 09:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the User Frontend plugin to the latest stable release (4.4 or newer) which removes the unsanitized parameter handling.
  • If a newer release cannot be applied immediately, remove or deactivate any shortcodes that expose the vulnerable form from publicly accessible pages, or prevent unauthorized users from accessing them.
  • As a temporary workaround, filter the 'field_attr[required]' input on submission to apply proper escaping or whitelist accepted values, and enforce a site-wide Content Security Policy that blocks inline script execution.

Generated by OpenCVE AI on October 31, 2026 at 09:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 31 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Description The User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'field_attr[required]' parameter in all versions up to, and including, 4.3.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The nonce check on the wpuf_get_child_cat AJAX action is not an effective security barrier because the wpuf_nonce value is publicly localized to every anonymous visitor of any page containing a WPUF shortcode, making it freely harvestable by an unauthenticated attacker.
Title User Frontend <= 4.3.13 - Reflected Cross-Site Scripting via 'field_attr[required]' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-31T07:46:50.023Z

Reserved: 2026-10-01T15:22:56.540Z

Link: CVE-2026-103962

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-31T08:16:47.613

Modified: 2026-10-31T08:16:47.613

Link: CVE-2026-103962

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-31T09:30:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')