Description
The Simple Shopping Cart WordPress plugin before 5.2.6 does not escape some of its settings field values before outputting them on an admin settings page, allowing high-privilege users such as administrators to perform Stored Cross-Site Scripting attacks, which is notably impactful on multisite installations where administrators do not have the unfiltered_html capability.
Published: 2026-10-04
Score: 3.5 Low
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Plugin
AI Analysis

Impact

The Simple Shopping Cart WordPress plugin before version 5.2.6 does not escape certain setting field values when rendering the admin settings page; administrators can embed arbitrary JavaScript that will execute in the browser context of any administrator who visits the settings page, potentially allowing credential theft, session hijacking or other client‑side compromise. The vulnerability is a stored client‑side flaw and does not provide a direct remote code execution path on the server.

Affected Systems

WordPress sites that use the Simple Shopping Cart plugin with any version earlier than 5.2.6 are affected. The issue impacts both single‑site and multisite networks, and is particularly serious on multisite installations where administrators lack the unfiltered_html capability.

Risk and Exploitability

This is an unfiltered input flaw that enables stored XSS in the admin settings page. No public exploit is known, and the CVSS score is 3.5 while the EPSS score is < 1%. The vulnerability is not listed in the CISA KEV catalog. Because it requires a user with administrator privileges to introduce the payload, the likelihood of exploitation depends on how easily an attacker can gain such access; once an attacker has admin rights, the impact can be high, allowing compromise of administrative sessions or injection of malicious client‑side code.

Generated by OpenCVE AI on October 5, 2026 at 12:57 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Simple Shopping Cart plugin to version 5.2.6 or newer.
  • Reapply any customized configuration settings after the update to ensure that stored values are rendered with proper escaping.
  • If an immediate update is not possible, disable the plugin or delete the PayPal API credentials from the settings page until the patch is deployed.

Generated by OpenCVE AI on October 5, 2026 at 12:57 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Mon, 05 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 3.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sun, 04 Oct 2026 22:15:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions simple Shopping Cart
Vendors & Products Wordpress-extensions
Wordpress-extensions simple Shopping Cart

Sun, 04 Oct 2026 08:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Sun, 04 Oct 2026 06:45:00 +0000

Type Values Removed Values Added
Description The Simple Shopping Cart WordPress plugin before 5.2.6 does not escape some of its settings field values before outputting them on an admin settings page, allowing high-privilege users such as administrators to perform Stored Cross-Site Scripting attacks, which is notably impactful on multisite installations where administrators do not have the unfiltered_html capability.
Title Simple Shopping Cart < 5.2.6 - Admin+ Stored XSS via PayPal API Credentials
References

Subscriptions

Wordpress-extensions Simple Shopping Cart
cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-05T10:53:49.430Z

Reserved: 2026-10-01T18:14:10.575Z

Link: CVE-2026-104119

cve-icon Vulnrichment

Updated: 2026-10-05T10:50:23.761Z

cve-icon NVD

Status : Deferred

Published: 2026-10-04T07:16:32.963

Modified: 2026-10-06T15:18:12.170

Link: CVE-2026-104119

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-05T13:00:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')