Impact
IBM Langflow OSS releases 1.0.0 through 1.12.2 contain a flaw where a malicious actor can supply manipulated content that the system accepts as executable code. The vulnerability, classified as CWE-94, allows an attacker to cause the server to run arbitrary code, potentially giving full control over the host machine or the application environment.
Affected Systems
The affected product is IBM Langflow OSS. Versions from 1.0.0 up to and including 1.12.2 are vulnerable; the recommendation is to upgrade to 1.12.3, which contains the fix.
Risk and Exploitability
The CVSS score of 9.8 denotes a critical severity, and although an EPSS score is not available, this indicates that exploit data is sparse or not yet measured. The vulnerability is not listed in the CISA KEV catalog. Based on the description, a direct network attack vector is inferred; any client with network access to the Langflow service could construct a payload that triggers the code execution pathway.
OpenCVE Enrichment