Description
Unauthenticated Cross Site Scripting (XSS) in picu <= 3.10.1 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is an unauthenticated Cross Site Scripting (XSS) flaw in the picu WordPress plugin up to version 3.10.1. The flaw allows an attacker to inject malicious script that is executed in the browsers of visitors to the site. This is an input validation weakness (CWE‑79) where untrusted data is displayed without proper encoding or sanitisation.

Affected Systems

The vulnerability impacts the picu WordPress plugin, specifically versions up to and including 3.10.1, used on WordPress sites. Users running these versions are susceptible if the plugin processes data from unauthenticated users.

Risk and Exploitability

The CVSS score of 7.1 assigns a high severity to the flaw. The EPSS score of 0.00237 (approximately 0.24%) indicates a very low exploitation probability. It is not listed in the CISA KEV catalog, indicating it has not yet been observed as part of an active exploitation campaign. The likely attack vector is an unauthenticated web user submitting malicious input through any form or endpoint handled by the picu plugin. Based on the description, exploitation requires no special privileges beyond normal web access.

Generated by OpenCVE AI on October 7, 2026 at 04:50 UTC.

Remediation

Vendor Solution

Update the WordPress picu plugin to the latest available version (at least 3.10.2).


OpenCVE Recommended Actions

  • Update the WordPress picu plugin to version 3.10.2 or later.
  • If an update cannot be applied immediately, disable or uninstall the picu plugin to eliminate the vulnerable code.
  • Apply general secure coding practices for WordPress sites: keep all core, themes, and plugins up to date, enforce a web application firewall or similar input filtering, and ensure that any data passed to the browser is properly escaped or encoded.

Generated by OpenCVE AI on October 7, 2026 at 04:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 21:15:00 +0000

Type Values Removed Values Added
First Time appeared Picu
Picu picu
Wordpress-extensions
Wordpress-extensions picu
Vendors & Products Picu
Picu picu
Wordpress-extensions
Wordpress-extensions picu

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in picu <= 3.10.1 versions.
Title WordPress picu plugin <= 3.10.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Picu Picu
Wordpress-extensions Picu
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:27.829Z

Reserved: 2026-10-02T00:22:13.105Z

Link: CVE-2026-104395

cve-icon Vulnrichment

Updated: 2026-10-06T10:28:15.799Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:38.570

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-104395

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:00:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')