Description
YesWiki before 4.6.7 contains an authorization bypass vulnerability in ApiService::isAuthorized() that allows unauthenticated attackers to call admin-only API routes when public API mode is enabled. Attackers can send requests to endpoints like api/ci/update_config and api/archives to overwrite configuration and list, download, or delete backup archives.
Published: 2026-10-02
Score: 9.2 Critical
EPSS: < 1% Very Low
KEV: No
Impact: Remote Authorization Bypass (Unauthenticated Execution of Admin API Calls)
Action: Patch Immediately
AI Analysis

Impact

YesWiki versions before 4.6.7 contain an authorization bypass flaw in ApiService::isAuthorized() that lets an unauthenticated user execute admin‑only API endpoints when public API mode is active. By sending requests to routes such as api/ci/update_config or api/archives, an attacker can overwrite site configuration and list, download, or delete backup archives. The vulnerability is a classic example of improper authorization (CWE‑862).

Affected Systems

The vulnerability affects the YesWiki content management system, specifically versions prior to 4.6.7, when the site is configured to allow public API access. Users should verify that their installation is running 4.6.7 or later or that the public API mode is disabled.

Risk and Exploitability

The CVSS score of 9.2 indicates a critical severity with full remote impact; the vulnerability is exploitable over the network via the public API layer. While EPSS data is not available, the lack of a KEV listing does not diminish the risk, as attackers can directly target exposed endpoints. The likely attack vector is a remote, unauthenticated request to the API endpoint, requiring no user credentials and offering privileged access to configuration and backup data.

Generated by OpenCVE AI on October 2, 2026 at 13:04 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the official YesWiki upgrade to version 4.6.7 or later, which removes the bypass in ApiService::isAuthorized().
  • If an immediate upgrade is not feasible, disable the public API mode in the YesWiki configuration to prevent external access to admin API routes.
  • After either action, verify that the affected API endpoints are no longer reachable by performing a test request to api/ci/update_config and confirming that it requires authentication or is blocked.

Generated by OpenCVE AI on October 2, 2026 at 13:04 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 02 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'poc', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 02 Oct 2026 11:45:00 +0000

Type Values Removed Values Added
Description YesWiki before 4.6.7 contains an authorization bypass vulnerability in ApiService::isAuthorized() that allows unauthenticated attackers to call admin-only API routes when public API mode is enabled. Attackers can send requests to endpoints like api/ci/update_config and api/archives to overwrite configuration and list, download, or delete backup archives.
Title YesWiki before 4.6.7 Authorization Bypass via Public API Mode
First Time appeared Yeswiki
Yeswiki yeswiki
Weaknesses CWE-862
CPEs cpe:2.3:a:yeswiki:yeswiki:*:*:*:*:*:*:*:*
Vendors & Products Yeswiki
Yeswiki yeswiki
References
Metrics cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}

cvssV4_0

{'score': 9.2, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-02T15:15:54.625Z

Reserved: 2026-10-02T00:55:11.982Z

Link: CVE-2026-104467

cve-icon Vulnrichment

Updated: 2026-10-02T15:15:37.788Z

cve-icon NVD

Status : Deferred

Published: 2026-10-02T12:17:19.373

Modified: 2026-10-02T16:16:46.357

Link: CVE-2026-104467

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-02T14:00:17Z

Weaknesses