Description
The weMail WordPress plugin through 2.1.6 does not correctly verify user capabilities in its REST API permission checks, treating any user whose role is in the weMail WordPress plugin through 2.1.6's allowed-roles list (Editor and above by default) as authorised for every action, which allows such users to perform administrator-level actions including enumerating all registered users with their email addresses and modifying the weMail WordPress plugin through 2.1.6's own access-control configuration.
Published: 2026-11-03
Score: n/a
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

The weMail WordPress plugin mischecks user capabilities in its REST API, granting any user with Editor or higher privileges full administrative access to the plugin. This flaw allows an attacker to enumerate all registered users and their email addresses, as well as modify the plugin’s configuration, thereby compromising confidentiality and integrity. The vulnerability represents a classic broken access control that could be leveraged to elevate privileges or harvest sensitive data.

Affected Systems

The affected software is the weMail WordPress plugin through version 2.1.6 and earlier. Any WordPress site deploying these plugin versions is impacted; the plugin’s default allowed‑roles list includes Editor and above, so sites that grant these roles are susceptible.

Risk and Exploitability

The flaw is exploitable via the plugin’s REST API, which is reachable over HTTP/HTTPS on the WordPress site. Because the plugin treats any Editor+ user as fully authorized, an attacker who gains access to such an account—through credential compromise or social engineering—can perform privileged actions without further authentication. No EPSS or KEV information and no CVSS score are provided, but the confirmed privilege escalation and data disclosure capabilities indicate a moderate‑to‑high risk, especially for sites with active editor accounts.

Generated by OpenCVE AI on November 3, 2026 at 07:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the weMail WordPress plugin to a version newer than 2.1.6 where the permission checks have been corrected.
  • If upgrading is delayed, restrict the plugin’s allowed‑roles list to remove the Editor role so that only administrators retain full access.
  • Apply firewall or web‑application rules to restrict external access to the plugin’s REST API endpoints, ensuring only trusted users can invoke them.

Generated by OpenCVE AI on November 3, 2026 at 07:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 03 Nov 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-284

Tue, 03 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The weMail WordPress plugin through 2.1.6 does not correctly verify user capabilities in its REST API permission checks, treating any user whose role is in the weMail WordPress plugin through 2.1.6's allowed-roles list (Editor and above by default) as authorised for every action, which allows such users to perform administrator-level actions including enumerating all registered users with their email addresses and modifying the weMail WordPress plugin through 2.1.6's own access-control configuration.
Title weMail <= 2.1.6 - Editor+ Incorrect Authorization via User::can()
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-03T06:00:24.437Z

Reserved: 2026-10-02T05:40:39.661Z

Link: CVE-2026-104647

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-03T06:17:37.123

Modified: 2026-11-03T06:17:37.123

Link: CVE-2026-104647

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-03T07:30:09Z

Weaknesses