Description
Unauthenticated Cross Site Scripting (XSS) in LearnPress <= 4.4.9 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Unauthenticated Cross Site Scripting
Action: Patch Now
AI Analysis

Impact

The vulnerability allows an unauthenticated attacker to inject arbitrary JavaScript into the LearnPress plugin via improperly sanitized input fields, resulting in a reflected or stored cross‑site scripting flaw (CWE‑79). If an attacker successfully injects malicious code, it will execute in the context of the victim’s browser or the site administrator’s session, potentially enabling cookie theft, session hijacking, or defacement of the WordPress site. The impact is limited to confidentiality, integrity, and availability of the web user interface.

Affected Systems

The affected vendor is ThimPress with its LearnPress plugin. Versions up to and including 4.4.9 are vulnerable, and at least 4.4.9.1 has been released to fix this flaw. All WordPress installations that have learned‑press plugin versions 4.4.9 or earlier should be treated as at risk.

Risk and Exploitability

The CVSS score of 7.1 indicates a high severity vulnerability. EPSS score of 0.18% and the flaw is not listed in the CISA KEV catalog. Based on the description, it is inferred that the likely attack vector is through crafted URLs or form submissions that include malicious script payloads, which can be triggered by any site visitor. Because no authentication is required, the flaw is readily exploitable, potentially leading to significant compromise of user sessions or site integrity.

Generated by OpenCVE AI on October 7, 2026 at 04:50 UTC.

Remediation

Vendor Solution

Update the WordPress LearnPress plugin to the latest available version (at least 4.4.9.1).


OpenCVE Recommended Actions

  • Update the LearnPress plugin to version 4.4.9.1 or later to eliminate the vulnerability
  • Remove any injected script reference or malicious code that may already exist in the site’s database or files
  • Configure a Content Security Policy to permit scripts only from trusted origins to provide an additional defense

Generated by OpenCVE AI on October 7, 2026 at 04:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 21:15:00 +0000

Type Values Removed Values Added
First Time appeared Thimpress
Thimpress learnpress
Wordpress-extensions
Wordpress-extensions learnpress
Vendors & Products Thimpress
Thimpress learnpress
Wordpress-extensions
Wordpress-extensions learnpress

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in LearnPress <= 4.4.9 versions.
Title WordPress LearnPress plugin <= 4.4.9 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Thimpress Learnpress
Wordpress-extensions Learnpress
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:27.439Z

Reserved: 2026-10-02T07:58:39.370Z

Link: CVE-2026-104670

cve-icon Vulnrichment

Updated: 2026-10-06T10:28:11.574Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:39.317

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-104670

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:00:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')