Description
Unauthenticated Cross Site Scripting (XSS) in GiveWP <= 4.17.0 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting in GiveWP plugin
Action: Update Plugin
AI Analysis

Impact

The vulnerability is an unauthenticated Cross Site Scripting flaw that allows an attacker to inject arbitrary JavaScript into the pages served by the GiveWP WordPress plugin whenever a user visits a compromised form or donation page. The injected code runs in the victim’s browser, potentially compromising client confidentiality or integrity.

Affected Systems

The flaw affects the Nexcess:GiveWP WordPress plugin versions 4.17.0 and earlier. Users running these editions on any WordPress installation are vulnerable until a patch is applied.

Risk and Exploitability

The CVSS score of 7.1 indicates moderate to high severity. Because the attack requires no authentication and can be triggered by any site visitor, the exploitability is high; the EPSS score of < 1% indicates a very low but non‑zero probability of exploitation, and the vulnerability is not listed in the CISA KEV catalog. The likely attack vector is an unauthenticated web user visiting a page that renders the plugin’s output, making the risk significant for exposed sites.

Generated by OpenCVE AI on October 7, 2026 at 04:50 UTC.

Remediation

Vendor Solution

Update the WordPress GiveWP plugin to the latest available version (at least 4.18.0).


OpenCVE Recommended Actions

  • Update the GiveWP plugin to version 4.18.0 or later on all WordPress sites.
  • Implement a Content Security Policy that limits scripts to trusted sources and disallows inline scripts to block XSS payloads.
  • Monitor logs for suspicious script injection attempts and review user activity for signs of credential theft.

Generated by OpenCVE AI on October 7, 2026 at 04:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 21:15:00 +0000

Type Values Removed Values Added
First Time appeared Nexcess
Nexcess givewp
Wordpress-extensions
Wordpress-extensions givewp
Vendors & Products Nexcess
Nexcess givewp
Wordpress-extensions
Wordpress-extensions givewp

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in GiveWP <= 4.17.0 versions.
Title WordPress GiveWP plugin <= 4.17.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Nexcess Givewp
Wordpress-extensions Givewp
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:27.261Z

Reserved: 2026-10-02T08:00:27.291Z

Link: CVE-2026-104672

cve-icon Vulnrichment

Updated: 2026-10-06T10:28:10.186Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:39.483

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-104672

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:00:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')