Description
Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected.

This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.

Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Published: 2026-10-05
Score: 9.8 Critical
EPSS: 1.4% Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

Apache Struts is vulnerable to improper neutralization of Expression Language (OGNL) statements when the legacy RESTful action mapper is used. An attacker can craft a request that injects an OGNL expression, allowing execution of arbitrary code on the server. This can compromise confidentiality, integrity, and availability of the affected application, potentially giving full system control to the attacker. This is a CWE-917 (Expression Language Injection) vulnerability.

Affected Systems

Apache Software Foundation’s Struts framework, specifically versions 2.0.0 through 2.3.37, 2.5.0 through 2.5.33, 6.0.0 through 6.11.0, and 7.0.0 through 7.3. The vulnerability applies only when the legacy RESTful action mapper is enabled; applications using the default mapper, restful2 mapper, or the Struts REST plugin are not affected.

Risk and Exploitability

The vulnerability carries a high exploitation risk because an attacker can deliver the payload via a normal HTTP request to the exposed REST endpoint. No credentials are required, and the vector is network-based. The CVSS score is 9.8, and the EPSS score is < 1%. The lack of mitigation in affected versions makes exploitation straightforward. The issue is not currently listed in CISA KEV, but the potential for remote code execution warrants immediate attention.

Generated by OpenCVE AI on October 7, 2026 at 06:55 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the application to Apache Struts 6.12.0 or 7.4.0, which disables the vulnerable mapper or restores the OGNL allowlist. This addresses the CWE-917 injection weakness.
  • If upgrading cannot be performed immediately, remove or disable the legacy RESTful action mapper from the Struts configuration so that no OGNL expressions are evaluated. This mitigates the CWE-917 vulnerability.
  • Review and tighten all configuration files to ensure that OGNL allowlist is enabled (in Struts 7.x) and that no other action mappers expose OGNL execution paths. This step limits the impact of the CWE-917 flaw.

Generated by OpenCVE AI on October 7, 2026 at 06:55 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 08 Oct 2026 19:15:00 +0000

Type Values Removed Values Added
CPEs cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*

Tue, 06 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}

cvssV3_1

{'score': 9.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'}


Tue, 06 Oct 2026 12:15:00 +0000

Type Values Removed Values Added
References
Metrics threat_severity

None

cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}

threat_severity

Important


Mon, 05 Oct 2026 21:30:00 +0000

Type Values Removed Values Added
First Time appeared Apache
Apache struts
Vendors & Products Apache
Apache struts

Mon, 05 Oct 2026 20:30:00 +0000

Type Values Removed Values Added
References

Mon, 05 Oct 2026 18:45:00 +0000

Type Values Removed Values Added
Description Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Title Apache Struts: OGNL injection in the legacy RESTful action mapper
Weaknesses CWE-917
References

cve-icon MITRE

Status: PUBLISHED

Assigner: apache

Published:

Updated: 2026-10-06T14:09:06.711Z

Reserved: 2026-10-02T10:53:37.312Z

Link: CVE-2026-104711

cve-icon Vulnrichment

Updated: 2026-10-06T14:08:59.528Z

cve-icon NVD

Status : Analyzed

Published: 2026-10-05T19:17:14.497

Modified: 2026-10-08T19:05:18.073

Link: CVE-2026-104711

cve-icon Redhat

Severity : Important

Publid Date: 2026-10-05T18:35:10Z

Links: CVE-2026-104711 - Bugzilla

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T07:00:14Z

Weaknesses
  • CWE-917

    Improper Neutralization of Special Elements used in an Expression Language Statement ('Expression Language Injection')