Description
The Advanced Form Integration — Connect Forms to 300+ Apps plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.10.2 via deserialization of untrusted input . This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. Exploitation requires that an administrator has previously configured at least one active NexForms integration (status=1) in the plugin's database table; in the free tier, only POST parameter keys containing the substrings 'name', 'email', 'first', or 'last' are routed to the vulnerable normalizer.
Published: 2026-11-07
Score: 8.1 High
EPSS: n/a
KEV: No
Impact: PHP Object Injection enabling potential remote code execution
Action: Patch Immediately
AI Analysis

Impact

The Advanced Form Integration plugin for WordPress is vulnerable to PHP Object Injection through deserialization of untrusted $_POST data. An unauthenticated attacker can send crafted POST parameters to a form that has at least one active NexForms integration, causing the plugin to instantiate a PHP object with attacker-controlled values. The vulnerability is mitigated only if the target site includes a plugin or theme that contains a suitable POSt chain, as no native chain exists within the plugin itself. When such a chain is present, the attacker can delete arbitrary files, read sensitive data, or execute arbitrary code, depending on the chain’s capabilities.

Affected Systems

WordPress sites running the Advanced Form Integration — Connect Forms to 300+ Apps plugin version 2.10.2 or earlier are affected. The plugin is maintained by nasirahmed. All installations that have the plugin enabled and have configured at least one active NexForms integration are susceptible.

Risk and Exploitability

The CVSS score of 8.1 indicates a high severity. The absence of an EPSS score means current exploitation probability is unknown, yet the vulnerability is readily exploitable via a simple HTTP POST request. The condition that a POP chain must exist in another plugin or theme lowers the immediate risk if no such chain is present, but the widespread use of the plugin makes the attack surface large. Because the vulnerability is unauthenticated, any user who can access the site’s form endpoints can attempt the exploit. Off‑the‑shelf mitigations, such as a web application firewall, may reduce exposure, but the definitive risk is mitigated only by patching the plugin or removing the vulnerable functionality.

Generated by OpenCVE AI on November 7, 2026 at 09:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Advanced Form Integration plugin to the latest version (greater than 2.10.2).
  • If updating is not immediately possible, temporarily disable or uninstall the plugin and its NexForms integrations until a fix is applied.
  • Configure the site to reject or sanitize any PHP object injection payloads in POST parameters, for example by implementing strict input validation or a custom filter.

Generated by OpenCVE AI on November 7, 2026 at 09:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 08:30:00 +0000

Type Values Removed Values Added
Description The Advanced Form Integration — Connect Forms to 300+ Apps plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.10.2 via deserialization of untrusted input . This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. Exploitation requires that an administrator has previously configured at least one active NexForms integration (status=1) in the plugin's database table; in the free tier, only POST parameter keys containing the substrings 'name', 'email', 'first', or 'last' are routed to the vulnerable normalizer.
Title Advanced Form Integration <= 2.10.2 - Unauthenticated PHP Object Injection via $_POST Parameters
Weaknesses CWE-502
References
Metrics cvssV3_1

{'score': 8.1, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T08:25:30.967Z

Reserved: 2026-10-02T11:53:33.141Z

Link: CVE-2026-104738

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T09:17:11.253

Modified: 2026-11-07T09:17:12.420

Link: CVE-2026-104738

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T09:30:12Z

Weaknesses
  • CWE-502

    Deserialization of Untrusted Data