Description
The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'conversion' Shortcode Attribute in all versions up to, and including, 1.10.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS) impacting authenticated contributors.
Action: Immediate Patch
AI Analysis

Impact

The If‑So Dynamic Content plugin allows contributors to attach arbitrary scripts via the 'conversion' shortcode. Because the input is not sanitized and the output is not escaped, an attacker with contributor privileges can place malicious JavaScript that executes for any visitor accessing the page. This gives the attacker the ability to deface, steal credentials, or redirect users. The weakness corresponds to CWE‑79.

Affected Systems

Users of If‑So Dynamic Content – Elementor & All Page Builders Personalization for WordPress, versions 1.10.2 and earlier, are affected. The flaw exists on all WordPress installations that include this plugin.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity. The vulnerability requires authentication as a contributor or higher and relies on a user’s browser to execute the injected script. No known public exploits are recorded and the EPSS score is not available, which suggests low to moderate exploitation probability. The plugin is not listed in the CISA KEV catalog.

Generated by OpenCVE AI on October 28, 2026 at 08:26 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the If‑So Dynamic Content plugin to a version newer than 1.10.2 or replace it with a secure alternative.
  • If an upgrade is not possible, restrict or remove contributor permissions for all users, assigning only authors or higher roles where absolutely necessary.
  • Implement a strict input validation and escaping policy for custom shortcodes, ensuring that any user‑supplied parameters are thoroughly sanitized before output, in line with CWE‑79 best practices.
  • Apply a Content‑Security‑Policy header to mitigate the impact of any potential XSS payloads, limiting script execution to trusted sources.

Generated by OpenCVE AI on October 28, 2026 at 08:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'conversion' Shortcode Attribute in all versions up to, and including, 1.10.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title If-So Dynamic Content <= 1.10.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'conversion' Shortcode Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:10.177Z

Reserved: 2026-10-02T11:54:05.189Z

Link: CVE-2026-104740

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:43.513

Modified: 2026-10-28T07:16:43.513

Link: CVE-2026-104740

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T08:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')