Description
The Kadence Blocks — Page Builder Toolkit for Gutenberg Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Block Font Family Attribute in all versions up to, and including, 3.7.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This encoding bypass is only triggered when the "Load Google Fonts Locally" site option (kadence_blocks_font_settings['load_fonts_local']) is enabled, which is not the default configuration.
Published: 2026-10-10
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Authenticated Stored XSS
Action: Apply Patch
AI Analysis

Impact

Kadence Blocks, a WordPress block plugin, contains a stored cross‑site scripting flaw in the font‑family attribute for all versions up to 3.7.12. Because the plugin fails to properly sanitize or escape user input, an attacker with author or higher privileges can inject arbitrary JavaScript into the page. When the injected scripts execute they run in the browser context of any visitor who loads the affected page, allowing the attacker to steal session cookies, deface content, or perform other malicious actions. The vulnerability is limited to situations where the "Load Google Fonts Locally" option is enabled, which is an additional configuration setting not enabled by default.

Affected Systems

The flaw applies only to the Kadence Blocks plugin for WordPress, specifically versions 3.7.12 and earlier. This includes all installations using this plugin on any WordPress site where the plugin is active.

Risk and Exploitability

The CVSS score of 6.4 rates the vulnerability as medium severity, and the EPSS score is not available, indicating unknown exploitation probability. The flaw is not listed in CISA's KEV catalog. Exploitation requires an authenticated author‑level user and the additional setting to be enabled, making it a privileged XSS scenario. Attackers would need to log into the WordPress backend to insert malicious font‑family code, after which any site visitor would be affected. Given these conditions, the risk is moderate but can have serious impact on privileged users and site visitors if the plugin is not patched or misconfiguration remains.

Generated by OpenCVE AI on October 10, 2026 at 06:51 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Kadence Blocks to version 3.7.13 or later, which removes the unsafe font‑family handling.
  • If an upgrade is delayed, disable the "Load Google Fonts Locally" setting in the plugin options to eliminate the code bypass path.
  • Restrict author and higher user roles to trusted contributors and review their content for script injection.
  • Consider sanitizing or removing the font‑family attribute from existing blocks if the setting must remain enabled.

Generated by OpenCVE AI on October 10, 2026 at 06:51 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 10 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Kadence Blocks — Page Builder Toolkit for Gutenberg Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Block Font Family Attribute in all versions up to, and including, 3.7.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This encoding bypass is only triggered when the "Load Google Fonts Locally" site option (kadence_blocks_font_settings['load_fonts_local']) is enabled, which is not the default configuration.
Title Kadence Blocks <= 3.7.12 - Authenticated (Author+) Stored Cross-Site Scripting via Block Font Family Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-11T12:23:57.373Z

Reserved: 2026-10-02T12:36:41.599Z

Link: CVE-2026-104762

cve-icon Vulnrichment

Updated: 2026-10-11T12:15:40.785Z

cve-icon NVD

Status : Deferred

Published: 2026-10-10T06:16:39.707

Modified: 2026-10-13T13:30:21.620

Link: CVE-2026-104762

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-10T07:00:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')