Description
The AGE-GATE plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.0 via the 'width (and height)' parameter parameter. This is due to missing authentication, capability checks, and nonce verification on the standalone admin.php endpoint, combined with unsanitized injection of POST parameters directly into generated PHP source written to an included file. This makes it possible for unauthenticated attackers to execute code on the server. This is possible because admin.php does not load WordPress and carries no ABSPATH guard, making it a fully unauthenticated entry point regardless of the decorative capability arguments registered via the plugin's simulated menu API.
Published: 2026-10-14
Score: 9.8 Critical
EPSS: 1.0% Low
KEV: No
Impact: Remote Code Execution
Action: Apply Patch
AI Analysis

Impact

The AGE-GATE WordPress plugin allows unauthenticated attackers to inject arbitrary PHP code via the width and height POST parameters sent to the admin.php endpoint. Because admin.php runs without WordPress authentication, capability checks, or nonce verification, the plugin writes these unsanitized inputs directly into a PHP source file that is included elsewhere, granting the attacker code execution on the web server. This flaw corresponds to CWE-434, where untrusted data leads to file manipulation and execution.

Affected Systems

WordPress sites using the streetforce1 AGE-GATE plugin, all versions up to and including 1.0, are affected. The vulnerability exists in the standalone admin.php script bundled with the plugin for these legacy releases.

Risk and Exploitability

With a CVSS score of 9.8, this issue is considered Critical. The EPSS score of 1% indicates a low but measurable likelihood of exploitation in the wild, and the vulnerability is not listed in the CISA KEV catalog. An attacker needs only to send a crafted POST request to admin.php from any host; no authentication or special privileges are required, making the attack path straightforward and highly damaging if successful.

Generated by OpenCVE AI on October 16, 2026 at 01:30 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the AGE-GATE plugin to the latest version (>=1.1) or remove it entirely
  • If immediate upgrade is not possible, restrict direct access to admin.php by adding an ABSPATH guard or by configuring the web server to deny requests to that file for unauthenticated users
  • Deploy a web application firewall or use .htaccess rules to block or monitor POST requests to admin.php and filter the width/height parameters for malicious content

Generated by OpenCVE AI on October 16, 2026 at 01:30 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 15 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 04:00:00 +0000

Type Values Removed Values Added
Description The AGE-GATE plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.0 via the 'width (and height)' parameter parameter. This is due to missing authentication, capability checks, and nonce verification on the standalone admin.php endpoint, combined with unsanitized injection of POST parameters directly into generated PHP source written to an included file. This makes it possible for unauthenticated attackers to execute code on the server. This is possible because admin.php does not load WordPress and carries no ABSPATH guard, making it a fully unauthenticated entry point regardless of the decorative capability arguments registered via the plugin's simulated menu API.
Title AGE-GATE <= 1.0 - Unauthenticated Remote Code Execution via PHP Code Injection via 'width'/'height' Parameters to Standalone admin.php
Weaknesses CWE-434
References
Metrics cvssV3_1

{'score': 9.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-15T16:43:50.515Z

Reserved: 2026-10-02T13:14:43.361Z

Link: CVE-2026-104800

cve-icon Vulnrichment

Updated: 2026-10-15T16:39:35.822Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T04:18:12.563

Modified: 2026-10-15T17:17:11.907

Link: CVE-2026-104800

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T01:45:19Z

Weaknesses
  • CWE-434

    Unrestricted Upload of File with Dangerous Type