Description
Unauthenticated Cross Site Scripting (XSS) in Form Block <= 1.8.1 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Unauthenticated Cross‑Site Scripting (XSS) that can execute malicious scripts in victim browsers
Action: Patch
AI Analysis

Impact

An unauthenticated Cross‑Site Scripting vulnerability exists in the WordPress Form Block plugin up to and including version 1.8.1. The flaw allows attackers to inject arbitrary scripts into pages that contain the plugin’s form elements. If the malicious payload is not properly sanitized, the script will run in the browsers of any user who views the affected page.

Affected Systems

The defect affects any site that installs the WordPress Form Block plugin version 1.8.1 or earlier from the vendor epiphyt. No other WordPress components are directly mentioned as impacted.

Risk and Exploitability

The CVSS score of 7.1 classifies the vulnerability as high severity. Because the flaw is unauthenticated, any visitor to the site can exploit it by submitting a crafted form or loading a page that contains the compromised form element; no additional conditions or privileges are required. The EPSS score is 0.00237, and the vulnerability has not been listed in the CISA KEV catalog, indicating no publicly known widespread exploitation yet. The likely attack vector involves an attacker embedding malicious JavaScript in form inputs that are rendered unsafely on the front‑end. Based on the description, it is inferred that attackers could achieve script execution in visitors’ browsers.

Generated by OpenCVE AI on October 7, 2026 at 04:49 UTC.

Remediation

Vendor Solution

Update the WordPress Form Block plugin to the latest available version (at least 1.8.2).


OpenCVE Recommended Actions

  • Update the WordPress Form Block plugin to version 1.8.2 or later. This release removes the XSS flaw by properly sanitizing user input before rendering it.
  • If an immediate update is not possible, disable or remove the Form Block plugin from the site until the patch is applied to prevent exploitation via form pages.
  • Implement sanitization or output‑escaping for any custom form content, ensuring that all user‑supplied data is passed through WordPress’s esc_html() or esc_js() functions before rendering.

Generated by OpenCVE AI on October 7, 2026 at 04:49 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 21:15:00 +0000

Type Values Removed Values Added
First Time appeared Epiph
Epiph form Block
Wordpress-extensions
Wordpress-extensions form Block
Vendors & Products Epiph
Epiph form Block
Wordpress-extensions
Wordpress-extensions form Block

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Form Block <= 1.8.1 versions.
Title WordPress Form Block plugin <= 1.8.1 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Epiph Form Block
Wordpress-extensions Form Block
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:26.835Z

Reserved: 2026-10-02T14:07:55.205Z

Link: CVE-2026-104814

cve-icon Vulnrichment

Updated: 2026-10-06T10:28:05.192Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:39.973

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-104814

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T05:00:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')