Description
Unauthenticated Cross Site Scripting (XSS) in WP Mailster <= 1.9.0.0 versions.
Published: 2026-10-06
Score: 7.1 High
EPSS: < 1% Very Low
KEV: No
Impact: Cross Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

The vulnerability permits unauthenticated attackers to inject arbitrary script through the WP Mailster plugin, potentially hijacking user sessions, defacing content, or spreading malware. This is a classic XSS flaw that undermines the confidentiality and integrity of site traffic and is classified as CWE‑79.

Affected Systems

The affected product is the WordPress WP Mailster plugin, versions 1.9.0.0 and earlier. Users running these versions on any WordPress installation are susceptible. The plugin is distributed under the brandtoss:WP Mailster product line.

Risk and Exploitability

The CVSS score of 7.1 indicates high severity. The EPSS score of < 1% indicates a very low exploitation probability. This vulnerability is not listed in CISA KEV, suggesting no widespread exploitation evidence yet. The likely attack vector is unauthenticated access to the plugin's public interface, allowing an attacker to craft a malicious payload that executes in the browsers of site visitors.

Generated by OpenCVE AI on October 6, 2026 at 15:20 UTC.

Remediation

Vendor Solution

Update the WordPress WP Mailster plugin to the latest available version (at least 1.9.1.0).


OpenCVE Recommended Actions

  • Apply the recommended patch by updating the WP Mailster plugin to version 1.9.1.0 or later.
  • If an immediate update is not feasible, temporarily uninstall or disable the WP Mailster plugin to eliminate the attack surface.
  • While the plugin remains active, restrict access to its management pages to trusted administrators and ensure all user inputs are properly sanitized to mitigate XSS.

Generated by OpenCVE AI on October 6, 2026 at 15:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 06 Oct 2026 21:15:00 +0000

Type Values Removed Values Added
First Time appeared Brandtoss
Brandtoss wpmailster
Wordpress-extensions
Wordpress-extensions wp Mailster
Vendors & Products Brandtoss
Brandtoss wpmailster
Wordpress-extensions
Wordpress-extensions wp Mailster

Tue, 06 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 09:00:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in WP Mailster <= 1.9.0.0 versions.
Title WordPress WP Mailster plugin <= 1.9.0.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Brandtoss Wpmailster
Wordpress-extensions Wp Mailster
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-06T10:31:26.294Z

Reserved: 2026-10-03T00:17:03.678Z

Link: CVE-2026-105061

cve-icon Vulnrichment

Updated: 2026-10-06T10:27:58.513Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T09:17:40.597

Modified: 2026-10-06T15:04:25.990

Link: CVE-2026-105061

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-06T20:54:28Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')