Description
Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.
Published: 2026-10-30
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

The vulnerability is an unauthenticated cross‑site scripting flaw that lets attackers inject malicious scripts into the Ad Inserter plugin’s content fields. Because the flaw can be exploited without authentication, an attacker can cause a site visitor to run arbitrary JavaScript in the visitor’s browser, which can lead to cookie theft, session hijacking, defacement or the delivery of malware. This is a CWE‑79 type flaw.

Affected Systems

The affected product is the Ad Inserter plugin developed by Spacetime. The vulnerability exists in all releases up to and including version 2.8.19. No other vendor or product versions are reported as affected.

Risk and Exploitability

The CVSS base score is 7.1, indicating a medium‑to‑high severity of the flaw. The EPSS value is not available, and the vulnerability is not listed in the CISA KEV catalog. Because it is unauthenticated, any user or attacker with access to the site’s public pages can deliver malicious input through the plugin’s interface, leading to client‑side code execution. No special prerequisites beyond exploiting the plugin’s input fields are required.

Generated by OpenCVE AI on October 30, 2026 at 19:26 UTC.

Remediation

Vendor Solution

Update to 2.8.20 or a higher version.


OpenCVE Recommended Actions

  • Upgrade the Ad Inserter plugin to version 2.8.20 or later.
  • If upgrading is not possible, disable the Ad Inserter plugin until a patched version is available.
  • Review the site for any injected scripts or malicious content and remove them.

Generated by OpenCVE AI on October 30, 2026 at 19:26 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 18:45:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.
Title WordPress Ad Inserter plugin <= 2.8.19 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-30T19:00:18.568Z

Reserved: 2026-10-03T00:17:03.679Z

Link: CVE-2026-105077

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-30T19:17:58.637

Modified: 2026-10-30T19:22:27.173

Link: CVE-2026-105077

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T19:30:11Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')