Description
The ACPT (Premium) plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.0.66 via the render function. This is due to missing capability check on the REST API form creation endpoint and unsandboxed Twig environment rendering email templates. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute code on the server. The exploit requires the attacker to first create a form with malicious email_settings via the REST API endpoint, then trigger form submission to execute the injected Twig expressions.
Published: 2026-10-06
Score: 8.8 High
EPSS: < 1% Very Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

The ACPT (Premium) plugin for WordPress is vulnerable to remote code execution due to a missing capability check on the REST API endpoint that creates forms and an unsandboxed Twig environment rendering email templates. An authenticated attacker with subscriber-level access can create a form containing malicious email_settings via the REST API. When the form is submitted, the plugin renders these settings with Twig and executes the injected expressions, giving the attacker the ability to run arbitrary code on the server. This flaw allows full compromise of the affected WordPress instance, potentially leaking data, modifying content, and hijacking administrative capabilities.

Affected Systems

The vulnerability applies to the ACPT (Premium) plugin developed by Mauro Cassani for WordPress versions 2.0.66 and earlier. Sites that installed any affected version are exposed. The vendor has released a fix in the changelog, so upgrading beyond 2.0.66 removes the risk.

Risk and Exploitability

The flaw has a CVSS score of 8.8, indicating a high-severity remote code execution flaw. EPSS data is not available and the vulnerability is not listed in CISA’s KEV catalog, suggesting no widespread exploitation at this time. However, the attack requires only subscription-level privileges, a common role in many sites, and the REST API is accessible over the network. Once authenticated, the attacker can exploit the endpoint with minimal effort, making the risk highly actionable.

Generated by OpenCVE AI on October 6, 2026 at 08:24 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the ACPT (Premium) plugin to a version newer than 2.0.66 to remove the vulnerability.
  • If an update cannot be applied immediately, disable the REST API form creation endpoint for subscriber-level users or any role below administrator so that only privileged editors or admins can create forms.
  • Restrict the creation of forms and the ability to submit data that triggers email template rendering by tightening user role permissions, ensuring that subscriber-level accounts have no rights to influence backend rendering.

Generated by OpenCVE AI on October 6, 2026 at 08:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 09 Oct 2026 09:15:00 +0000

Type Values Removed Values Added
First Time appeared Mauro Cassani
Mauro Cassani acpt (premium)
Wordpress-extensions
Wordpress-extensions acpt (premium)
Vendors & Products Mauro Cassani
Mauro Cassani acpt (premium)
Wordpress-extensions
Wordpress-extensions acpt (premium)

Tue, 06 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Tue, 06 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The ACPT (Premium) plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.0.66 via the render function. This is due to missing capability check on the REST API form creation endpoint and unsandboxed Twig environment rendering email templates. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute code on the server. The exploit requires the attacker to first create a form with malicious email_settings via the REST API endpoint, then trigger form submission to execute the injected Twig expressions.
Title ACPT (Premium) <= 2.0.66 - Authenticated (Subscriber+) Remote Code Execution via REST API Email Template
Weaknesses CWE-434
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

Mauro Cassani Acpt (premium)
Wordpress-extensions Acpt (premium)
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-06T16:06:34.387Z

Reserved: 2026-10-05T17:58:33.578Z

Link: CVE-2026-105701

cve-icon Vulnrichment

Updated: 2026-10-06T16:06:30.214Z

cve-icon NVD

Status : Deferred

Published: 2026-10-06T07:16:56.207

Modified: 2026-10-06T17:17:18.690

Link: CVE-2026-105701

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T08:44:54Z

Weaknesses
  • CWE-434

    Unrestricted Upload of File with Dangerous Type