Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BdThemes Element Pack Elementor Addons bdthemes-element-pack-lite allows Stored XSS.This issue affects Element Pack Elementor Addons: from n/a through 8.8.6.
Published: 2026-10-07
Score: 6.5 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch
AI Analysis

Impact

Improper neutralization of user input during page generation enables the BdThemes Element Pack Elementor Addons plugin to store malicious scripts. When a compromised element renders the stored content, the browser executes the injected script within the site’s context, allowing an attacker to hijack sessions, exfiltrate data, or deface the website. This flaw is a classic example of input validation failure as identified by CWE‑79.

Affected Systems

The vulnerability affects the WordPress Element Pack Elementor Addons plugin provided by BdThemes. All releases from the earliest available version through 8.8.6 contain the flaw; upgrading to any version 8.8.7 or newer removes the risk. No specific sub‑components or configuration settings are exempt within the affected range.

Risk and Exploitability

The CVSS score of 6.5 indicates moderate severity. Because no EPSS value is supplied, the current exploitation probability is unknown, and the flaw is not listed in the CISA KEV catalog. Based on the description, the likely attack vector is through user‑supplied content that the plugin stores and then surfaces without proper escaping, meaning an attacker can inject payloads via form fields or management interfaces that persist and later execute in the browsers of site visitors.

Generated by OpenCVE AI on October 7, 2026 at 11:22 UTC.

Remediation

Vendor Solution

Update the WordPress Element Pack Elementor Addons plugin to the latest available version (at least 8.8.7).


OpenCVE Recommended Actions

  • Update the Element Pack Elementor Addons plugin to version 8.8.7 or later.
  • If an upgrade is not immediately possible, disable the plugin to eliminate the stored XSS vectors.
  • Implement a web application firewall rule set that detects and blocks cross‑site scripting payloads to provide a temporary safeguard.

Generated by OpenCVE AI on October 7, 2026 at 11:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 07 Oct 2026 10:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 07 Oct 2026 09:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BdThemes Element Pack Elementor Addons bdthemes-element-pack-lite allows Stored XSS.This issue affects Element Pack Elementor Addons: from n/a through 8.8.6.
Title WordPress Element Pack Elementor Addons plugin <= 8.8.6 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-07T10:10:00.383Z

Reserved: 2026-10-06T00:18:26.654Z

Link: CVE-2026-105871

cve-icon Vulnrichment

Updated: 2026-10-07T10:03:37.662Z

cve-icon NVD

Status : Deferred

Published: 2026-10-07T10:17:34.920

Modified: 2026-10-07T13:24:53.103

Link: CVE-2026-105871

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-07T11:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')