Description
Deserialization of Untrusted Data vulnerability in mklacroix Product Configurator for WooCommerce product-configurator-for-woocommerce allows Object Injection.This issue affects Product Configurator for WooCommerce: from n/a through 1.7.5.
Published: 2026-10-09
Score: 7.2 High
EPSS: < 1% Very Low
KEV: No
Impact: Object injection leading to potential arbitrary code execution
Action: Immediate Patch
AI Analysis

Impact

The vulnerability arises from improper deserialization of untrusted data in the Product Configurator for WooCommerce plugin, allowing an attacker to inject malicious PHP objects. This flaw is identified as CWE-502 and can enable arbitrary code execution if an attacker can control the serialized payload processed by the plugin. The injected object can override properties or invoke methods that grant the attacker elevated privileges or further compromise the hosting WordPress site.

Affected Systems

The affected product is the WordPress Product Configurator for WooCommerce plugin developed by mklacroix, with all releases up to and including version 1.7.5 vulnerable. Any WordPress site that has this plugin installed at these or earlier versions is at risk unless the plugin is updated.

Risk and Exploitability

The CVSS score of 7.2 indicates a high severity risk, and while the EPSS score is not available, the lack of inclusion in the CISA KEV catalog does not diminish the potential impact. The likely attack vector is a web-based request that includes a crafted serialized string, which the plugin deserializes without proper validation. Although the exact prerequisite conditions are not detailed in the advisory, an attacker who can submit such a payload—whether through a public-facing form or a privileged user session—could potentially execute arbitrary code on the server.

Generated by OpenCVE AI on October 9, 2026 at 13:27 UTC.

Remediation

Vendor Solution

Update the WordPress Product Configurator for WooCommerce plugin to the latest available version (at least 1.7.6).


OpenCVE Recommended Actions

  • Update the Product Configurator for WooCommerce plugin to version 1.7.6 or later
  • If an update cannot be performed immediately, disable the plugin until the patch is applied
  • Implement access controls or firewall rules to restrict which users can reach the plugin’s deserialization endpoints

Generated by OpenCVE AI on October 9, 2026 at 13:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Description Deserialization of Untrusted Data vulnerability in mklacroix Product Configurator for WooCommerce product-configurator-for-woocommerce allows Object Injection.This issue affects Product Configurator for WooCommerce: from n/a through 1.7.5.
Title WordPress Product Configurator for WooCommerce plugin <= 1.7.5 - PHP Object Injection vulnerability
Weaknesses CWE-502
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-11T12:13:41.572Z

Reserved: 2026-10-06T00:18:26.655Z

Link: CVE-2026-105872

cve-icon Vulnrichment

Updated: 2026-10-11T12:06:51.932Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T13:17:08.957

Modified: 2026-10-11T13:17:11.693

Link: CVE-2026-105872

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T13:30:05Z

Weaknesses
  • CWE-502

    Deserialization of Untrusted Data