Description
The Menu Cart for WooCommerce WordPress plugin before 3.2.1 does not sanitise and escape cart item variation data before outputting it in its cart slide-out, allowing unauthenticated users to store a Cross-Site Scripting payload that can be delivered to and executed in the session of another user, including a logged-in administrator.
Published: 2026-10-28
Score: n/a
EPSS: n/a
KEV: No
Impact: Unauthenticated Stored XSS
Action: Upgrade Plugin
AI Analysis

Impact

The vulnerability exists in the Menu Cart for WooCommerce WordPress plugin before version 3.2.1, where cart item variation data is not properly sanitised or escaped before being rendered in the cart slide‑out. This allows an unauthenticated user to inject a malicious script that is stored and later executed in another user’s browser session, including the sessions of administrators. The flaw enables the execution of arbitrary client‑side code, potentially compromising the confidentiality, integrity, or availability of the site’s front‑end.

Affected Systems

Any WordPress installation running the Menu Cart for WooCommerce plugin with a version earlier than 3.2.1 is affected. No specific WordPress core version is required for the flaw but the plugin must be installed.

Risk and Exploitability

The vulnerability can be exploited by any external user who can add items to the cart and supply variation data. Because the payload is stored, the attack is persistent and will affect all subsequent users who see the compromised cart. The EPSS score is not available and the flaw is not listed in the CISA KEV catalog, suggesting limited current exploitation data. Nevertheless, the lack of input sanitisation combined with the ability to affect logged‑in administrators makes the risk significant enough to warrant immediate remediation.

Generated by OpenCVE AI on October 28, 2026 at 07:29 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Menu Cart for WooCommerce to version 3.2.1 or later
  • If an upgrade is not possible, temporarily disable or remove the plugin until a patched version is released
  • Implement client‑side input validation or an additional security module that filters out script tags (CWE-79 mitigation)

Generated by OpenCVE AI on October 28, 2026 at 07:29 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Wed, 28 Oct 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Menu Cart for WooCommerce WordPress plugin before 3.2.1 does not sanitise and escape cart item variation data before outputting it in its cart slide-out, allowing unauthenticated users to store a Cross-Site Scripting payload that can be delivered to and executed in the session of another user, including a logged-in administrator.
Title WooCommerce Menu Cart < 3.2.1 - Unauthenticated Stored XSS via Cart Item Variation Attribute
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-28T06:00:21.162Z

Reserved: 2026-10-06T09:25:53.271Z

Link: CVE-2026-105972

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T06:16:32.353

Modified: 2026-10-28T06:16:32.353

Link: CVE-2026-105972

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T07:30:11Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')