Description
Memory overflow vulnerability leading to Remote Code Execution or Denial of Service Vulnerability in NetScaler ADC.


NetScaler ADC or NetScaler Gateway must be configured as a SAML SP or SAML IdP, subject to the following version-specific requirements:



 

* For the following versions: Applicable only when configured as a SAML IdP:
* NetScaler ADC and NetScaler Gateway between 14.1-73.37 and 14.1-73.41, inclusive
* NetScaler ADC 14.1-FIPS between 14.1-73.37 FIPS and 14.1-73.41 FIPS, inclusive
* NetScaler ADC and NetScaler Gateway between 13.1-64.23 and 13.1-64.28, inclusive
* NetScaler ADC 13.1-FIPS between 13.1-NDcPP 13.1-37.279 and 13.1- 37.282, inclusive




 



For the following versions: Applicable only when configured as a SAML SP or SAML IdP:

* NetScaler ADC and NetScaler Gateway before 14.1-73.37 
* NetScaler ADC 14.1-FIPS before 14.1-73.37 FIPS 
* NetScaler ADC and NetScaler Gateway before 13.1-64.23
* NetScaler ADC 13.1-FIPS before13.1-NDcPP 13.1-37.279
Published: 2026-10-08
Score: 9.5 Critical
EPSS: 1.9% Low
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

A memory overflow flaw in NetScaler ADC and NetScaler Gateway allows a remote attacker to execute arbitrary code or cause a denial of service. The vulnerability arises when the device is configured as a SAML Service Provider or Identity Provider, and buffer overflow is triggered during SAML processing. Based on the description, it is inferred that exploited traffic targets the SAML protocol handling components.

Affected Systems

NetScaler ADC and NetScaler Gateway are affected when operating as either a SAML SP or SAML IdP. All versions up to and including 14.1‑73.41 (and all earlier releases) are impacted, as well as the corresponding FIPS releases up to and including 14.1‑73.41 FIPS. The 13.1 product line is vulnerable up to and including 13.1‑64.28, and 13.1‑37.282 FIPS (and all earlier 13.1 releases). Any device whose firmware falls within these ranges, regardless of role, must be remediated.

Risk and Exploitability

The CVSS score of 9.5 indicates a very high severity, and the EPSS score of 2% suggests a low but non‑zero likelihood of exploitation. The vulnerability is not listed in the CISA KEV catalog, yet the availability of remote code execution warrants a precautionary approach. The likely attack vector is through SAML traffic or configuration handling, meaning that remote actors able to influence SAML interactions can exploit the overflow.

Generated by OpenCVE AI on October 25, 2026 at 16:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the current Citrix security patch for NetScaler ADC and NetScaler Gateway that fixes the memory overflow issue.
  • Upgrade the devices to firmware newer than 14.1‑73.41, 13.1‑64.28, or the corresponding newer FIPS releases identified in the vendor advisory.
  • If upgrading is not immediately possible, reconfigure the system to disable SAML Service Provider or Identity Provider functionality until the patch can be applied.
  • Monitor SAML‑related logs and network traffic for anomalous activity that might indicate exploitation attempts.

Generated by OpenCVE AI on October 25, 2026 at 16:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 09 Oct 2026 16:00:00 +0000

Type Values Removed Values Added
Weaknesses CWE-120

Fri, 09 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-119
References
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 01:15:00 +0000

Type Values Removed Values Added
First Time appeared Netscaler
Netscaler adc
Netscaler gateway
Vendors & Products Netscaler
Netscaler adc
Netscaler gateway

Thu, 08 Oct 2026 23:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-120

Thu, 08 Oct 2026 21:30:00 +0000

Type Values Removed Values Added
Description Memory overflow vulnerability leading to Remote Code Execution or Denial of Service Vulnerability in NetScaler ADC. NetScaler ADC or NetScaler Gateway must be configured as a SAML SP or SAML IdP, subject to the following version-specific requirements:   * For the following versions: Applicable only when configured as a SAML IdP: * NetScaler ADC and NetScaler Gateway between 14.1-73.37 and 14.1-73.41, inclusive * NetScaler ADC 14.1-FIPS between 14.1-73.37 FIPS and 14.1-73.41 FIPS, inclusive * NetScaler ADC and NetScaler Gateway between 13.1-64.23 and 13.1-64.28, inclusive * NetScaler ADC 13.1-FIPS between 13.1-NDcPP 13.1-37.279 and 13.1- 37.282, inclusive   For the following versions: Applicable only when configured as a SAML SP or SAML IdP: * NetScaler ADC and NetScaler Gateway before 14.1-73.37  * NetScaler ADC 14.1-FIPS before 14.1-73.37 FIPS  * NetScaler ADC and NetScaler Gateway before 13.1-64.23 * NetScaler ADC 13.1-FIPS before13.1-NDcPP 13.1-37.279
Title Memory overflow vulnerability leading to Remote Code Execution or Denial of Service
References
Metrics cvssV4_0

{'score': 9.5, 'vector': 'CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L'}


cve-icon MITRE

Status: PUBLISHED

Assigner: NetScaler

Published:

Updated: 2026-10-10T03:55:21.152Z

Reserved: 2026-10-08T00:18:26.020Z

Link: CVE-2026-107406

cve-icon Vulnrichment

Updated: 2026-10-09T12:52:15.188Z

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-10-08T22:17:26.847

Modified: 2026-10-10T04:18:09.503

Link: CVE-2026-107406

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-25T16:30:16Z

Weaknesses
  • CWE-119

    Improper Restriction of Operations within the Bounds of a Memory Buffer