Description
Missing Authorization vulnerability in Cool Plugins AI Translation for Polylang automatic-translations-for-polylang allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AI Translation for Polylang: from n/a through 1.6.2.
Published: 2026-10-09
Score: 5.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Unauthorized Access via Broken Access Control
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a missing authorization flaw (CWE-862) in the Cool Plugins AI Translation for Polylang WordPress plugin. It allows an attacker to exploit incorrectly configured access control security levels, enabling unauthorized use of the plugin’s administrative functions. The impact is that an attacker who can reach the plugin’s interfaces may change translation settings or otherwise manipulate the plugin’s behavior without proper role validation.

Affected Systems

Affected products include the WordPress AI Translation for Polylang plugin from Cool Plugins, versions from an unknown earliest version through 1.6.2. Owners of sites using any of these plugin versions are at risk.

Risk and Exploitability

The CVSS score of 5.4 indicates a moderate risk level. EPSS is not available, and the vulnerability is not listed in the CISA KEV catalog. The likely attack vector is remote, via HTTP requests to the plugin’s endpoints, and would require that the site hosts the legacy plugin and that the attacker can send crafted requests. Because the flaw is an authorization bypass, it can be leveraged if the attacker can reach the plugin’s administrative functions, but it does not lead directly to remote code execution.

Generated by OpenCVE AI on October 9, 2026 at 13:54 UTC.

Remediation

Vendor Solution

Update the WordPress AI Translation for Polylang plugin to the latest available version (at least 1.6.3).


OpenCVE Recommended Actions

  • Update the AI Translation for Polylang plugin to version 1.6.3 or later.
  • Restrict the plugin’s administrative capabilities to trusted user roles and remove unnecessary permissions from other roles.
  • Configure the web server or application firewall to block direct access to the plugin’s administrative endpoints for anonymous or unauthorized IP ranges.

Generated by OpenCVE AI on October 9, 2026 at 13:54 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 13:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 09 Oct 2026 11:30:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in Cool Plugins AI Translation for Polylang automatic-translations-for-polylang allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AI Translation for Polylang: from n/a through 1.6.2.
Title WordPress AI Translation for Polylang plugin <= 1.6.2 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-11T12:13:41.693Z

Reserved: 2026-10-08T00:19:19.565Z

Link: CVE-2026-107419

cve-icon Vulnrichment

Updated: 2026-10-11T12:06:53.168Z

cve-icon NVD

Status : Deferred

Published: 2026-10-09T12:17:08.870

Modified: 2026-10-11T13:17:12.533

Link: CVE-2026-107419

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-09T14:00:07Z

Weaknesses