Description
The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_title' parameter in all versions up to, and including, 2.8.190 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-14
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Immediate Patch
AI Analysis

Impact

The GeoDirectory WP Business Directory plugin is vulnerable to a stored Cross‑Site Scripting flaw that allows authenticated users with subscriber‑level access and higher to inject arbitrary JavaScript into the post_title field. Because the title is output without proper sanitization or escaping, the injected script is rendered and executed whenever any user visits the affected listing page. This can lead to session hijacking, credential theft, defacement or other malicious activity on the website’s visitors.

Affected Systems

The vulnerability affects the GeoDirectory plugin from the paoltaia vendor, affecting all WordPress installations that use versions up to and including 2.8.190. Any site that has not upgraded beyond 2.8.190 is potentially exposed.

Risk and Exploitability

The CVSS score of 6.4 classifies the flaw as medium severity. The EPSS score is below 1%, indicating that the likelihood of widespread exploitation is low at present, and the vulnerability is not listed in the CISA KEV catalog. However, because the attack requires only legitimate subscriber‑level access—a status that many sites grant to a broad group of users—the vector is readily available to attackers who can edit listing titles. Once injected, the payload will execute in the browsers of all visitors who view the compromised listing. The overall risk remains moderate but warrants prompt attention.

Generated by OpenCVE AI on October 16, 2026 at 00:44 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the GeoDirectory plugin to the latest stable release that removes the XSS flaw (any version newer than 2.8.190).
  • Review existing listings and strip out any malicious code that may have been injected into post titles or other dynamic content fields.
  • Limit the ability to edit listing titles to administrator or higher‑privilege roles, or otherwise restrict subscriber actions that allow content modification.
  • Adopt secure coding practices consistent with CWE-79 by validating and escaping user‑supplied content before rendering dynamic fields.

Generated by OpenCVE AI on October 16, 2026 at 00:44 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 14 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 14 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Description The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_title' parameter in all versions up to, and including, 2.8.190 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title GeoDirectory <= 2.8.190 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Dynamic Content Field-Token Substitution via Listing Title
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-14T14:27:08.058Z

Reserved: 2026-10-08T14:23:15.216Z

Link: CVE-2026-107650

cve-icon Vulnrichment

Updated: 2026-10-14T14:27:03.768Z

cve-icon NVD

Status : Deferred

Published: 2026-10-14T08:17:04.417

Modified: 2026-10-14T15:17:06.473

Link: CVE-2026-107650

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-16T00:45:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')