Description
The BuddyForms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bf_post_type (and buddyforms_form_content)' parameter in all versions up to, and including, 2.10.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that at least one BuddyForms form with public submissions enabled exists on the site (so that the required nonce can be harvested from the public form page) and that the active theme registers a widgetized sidebar, allowing the injected customize_changeset to place a malicious Custom HTML widget into the site's front end.
Published: 2026-11-06
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross-Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability allows an attacker to store malicious scripts via the bf_post_type (and buddyforms_form_content) parameter in public forms. A user who views a page containing the injected contents will trigger the script, enabling potential theft of session data, defacement, or further attacks. It is a CWE-79 input validation and output escaping flaw. The flaw can be exploited without authentication, affecting sites where at least one BuddyForms form accepts public submissions.

Affected Systems

BuddyForms plugin for WordPress in any version up to and including 2.10.5. The issue requires a public form that includes a nonce and an active widgetized sidebar to deliver the malicious content.

Risk and Exploitability

The CVSS score of 5.4 indicates moderate severity. The EPSS score is not available, so the likelihood of exploitation remains uncertain, but the flaw is not listed in the CISA KEV catalog. Attackers would need to exploit a public form and a widgetized sidebar; once the script runs it executes with the privileges of the visiting user. The vulnerability is exploitable without authentication but requires visible public submission capability and active sidebars.

Generated by OpenCVE AI on November 6, 2026 at 12:22 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Apply the latest BuddyForms update that removes storage of the bf_post_type parameter from public forms.
  • If an update is unavailable, disable public form submissions or restrict the bf_post_type parameter to authenticated users only.
  • Remove or disable any widgetized sidebars that may host injected custom HTML widgets until the plugin is patched.

Generated by OpenCVE AI on November 6, 2026 at 12:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The BuddyForms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bf_post_type (and buddyforms_form_content)' parameter in all versions up to, and including, 2.10.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that at least one BuddyForms form with public submissions enabled exists on the site (so that the required nonce can be harvested from the public form page) and that the active theme registers a widgetized sidebar, allowing the injected customize_changeset to place a malicious Custom HTML widget into the site's front end.
Title BuddyForms <= 2.10.5 - Unauthenticated Stored Cross-Site Scripting via 'bf_post_type' Parameter via Post-Type Confusion
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T11:17:40.242Z

Reserved: 2026-10-08T14:36:36.802Z

Link: CVE-2026-107658

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:16.187

Modified: 2026-11-06T12:17:16.317

Link: CVE-2026-107658

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T12:30:04Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')