Description
The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content[title]' parameter in all versions up to, and including, 7.8.14.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has explicitly granted the 'Create and Update Modules' (hustle_create / hustle_edit_module) capability to the attacker's role via the plugin's own Settings → Permissions feature; this delegation is not enabled by default.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Restrict Permissions
AI Analysis

Impact

The vulnerability allows an authenticated attacker with the capability to create or edit modules to store malicious JavaScript in the Module Content Title field. Because the plugin does not properly sanitize or escape this input, the script is rendered and executed by any user who views the affected page, leading to cross‑site scripting on a page in the victim’s browser. This class of flaw lets an attacker execute arbitrary code in the context of the site’s users, enabling phishing, cookie theft, or defacement. The weakness is classified as CWE‑79.

Affected Systems

WordPress sites running the Hustle email, lead generation, opt‑in, and popup plugin from wpmudev, version 7.8.14.3 or earlier. The flaw is present in all releases up to and including this version and requires that an attacker’s role be granted the "Create and Update Modules" capability, typically available to Contributors and higher when the plugin’s Permissions settings are enabled.

Risk and Exploitability

The CVSS score of 6.4 indicates a moderate severity impact. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog. Exploitation requires an authenticated user who has been delegated module creation or editing rights via the plugin’s Settings → Permissions feature. Once that privilege is granted, attackers can inject trusted scripts that will run for any visitor accessing the injected module page. Because this privilege delegation is not enabled by default, the risk is limited to environments where admins have explicitly expanded Contributor capabilities.

Generated by OpenCVE AI on October 28, 2026 at 09:23 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Restrict the plugin’s Permissions settings so that only trusted administrators have the 'Create and Update Modules' capability and remove this capability from Contributors and other untrusted roles.
  • Deploy an application‑level firewall rule or Content Security Policy that blocks or sanitizes script injection in the content[title] field to provide a temporary mitigation while awaiting an official patch.
  • Monitor site logs and user activity for unauthorized module creation or script injection attempts to detect potential exploitation early.
  • Check the vendor’s website for updates or patches that address this vulnerability and apply them as soon as they are released.

Generated by OpenCVE AI on October 28, 2026 at 09:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content[title]' parameter in all versions up to, and including, 7.8.14.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has explicitly granted the 'Create and Update Modules' (hustle_create / hustle_edit_module) capability to the attacker's role via the plugin's own Settings → Permissions feature; this delegation is not enabled by default.
Title Hustle <= 7.8.14.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Module Content Title
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T16:09:34.692Z

Reserved: 2026-10-08T17:17:25.990Z

Link: CVE-2026-107710

cve-icon Vulnrichment

Updated: 2026-10-28T14:36:39.125Z

cve-icon NVD

Status : Deferred

Published: 2026-10-28T07:16:43.810

Modified: 2026-10-28T16:17:00.310

Link: CVE-2026-107710

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T09:30:20Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')